Foros del Web » Programando para Internet » PHP »

No me funcionan las variables predefinidas en PHP

Estas en el tema de No me funcionan las variables predefinidas en PHP en el foro de PHP en Foros del Web. Hola, estoy leyendo el libro: creacion de un portal con php y mysql, y viene un ejemplo que se supone deve arrojar los datos en ...
  #1 (permalink)  
Antiguo 16/07/2012, 21:33
Avatar de angelsanchezjr  
Fecha de Ingreso: mayo-2011
Ubicación: Mazatlan
Mensajes: 87
Antigüedad: 8 años, 3 meses
Puntos: 1
No me funcionan las variables predefinidas en PHP

Hola, estoy leyendo el libro: creacion de un portal con php y mysql, y viene un ejemplo que se supone deve arrojar los datos en el navegador como cual es el ip, el navegador etc usando las variables predefinidas de php, es este: pero no me da nindun resultado en el navegador salvo una pantalla blanca con los echo de que va a mostrar algo, pero no imprime la informacion de los echo de las variables predefinidas, que sera? muchas gracias por cualquier ayuda.

Código PHP:
<?php 
echo "Bienvenido a nuestro portal.";
echo 
"<br><br>";
echo
"Usted esta usando el navegador: ";
echo 
$http_user_agent;
echo 
"<br><br>";
echo
"su direccion IP es: ";
echo 
$REMOTE_ADDR;
echo 
"<br><br>";
echo
"El puerto que utiliza para conectarse al servidor web es: ";
echo 
$SERVER_PORT;

echo 
"<br><br>";
echo 
"Y viene de visitar: ";
echo 
$HTTP_REFERER;
echo 
"<br><br>";
echo 
"El nombre del servidor al que se conecta es: ";
echo 
$SERVER_NAME;
echo 
"<br><br>";
echo 
"El directorio en el que se almacenan los ficheros es :";
echo 
$DOCUMENT_ROOT;
echo 
"<br> <br>";
echo 
"El fichero PHP que está ejecutando se llama: ";
echo 
$SCRIPT_NAME;
echo 
"<br><br>";
echo 
"El correo del administrador del servidor es: ";
echo 
$SERVER_ADMIN;
echo 
"<br><br>";
echo 
"Versión del servidor y nombre del servidor virtual: ";
echo 
$SERVER_SIGNATURE;
echo 
"<br><br>";
echo 
"Sistema operativo: ";
echo 
$OS;
?>
  #2 (permalink)  
Antiguo 16/07/2012, 21:54
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 13 años, 2 meses
Puntos: 2135
Respuesta: No me funcionan las variables predefinidas en PHP

Ahora se debe de usar la variable $_SERVER, es decir:
Código PHP:
Ver original
  1. // mal
  2. $SERVER_NAME;
  3. // bien
  4. $_SERVER['SERVER_NAME'];

Saludos.
  #3 (permalink)  
Antiguo 17/07/2012, 11:33
Avatar de angelsanchezjr  
Fecha de Ingreso: mayo-2011
Ubicación: Mazatlan
Mensajes: 87
Antigüedad: 8 años, 3 meses
Puntos: 1
Respuesta: No me funcionan las variables predefinidas en PHP

Gracias amigo, si me funciono, pero y las demas? no funciona ninguna, como le hago? hay alguna pagina donde pueda ver las nuevas por que ya busque por todos lados y no halle nada, nomas puros scripts laaaaargos pero de estas variables nada
Gracias por tu contribucion
  #4 (permalink)  
Antiguo 17/07/2012, 11:37
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 13 años, 2 meses
Puntos: 2135
Respuesta: No me funcionan las variables predefinidas en PHP

Sigue la estructura, todas las variables ahora están adentro de $_SERVER, en el Manual puedes ver toda la referencia de variables.

Saludos.
  #5 (permalink)  
Antiguo 19/07/2012, 10:19
Avatar de angelsanchezjr  
Fecha de Ingreso: mayo-2011
Ubicación: Mazatlan
Mensajes: 87
Antigüedad: 8 años, 3 meses
Puntos: 1
Respuesta: No me funcionan las variables predefinidas en PHP

Gracias , ya lo encontre en la pagina que me mandaste

Etiquetas: funcionan, mysql, variables
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:53.