Foros del Web » Programando para Internet » PHP »

No hay paso de variables!! AYUDA!

Estas en el tema de No hay paso de variables!! AYUDA! en el foro de PHP en Foros del Web. Saludos, instale IIS 4 en mi maquina, y sobre ella la version 4.2.1 de PHP, y ya logre que funcione, pero tengo un problema, cuando ...
  #1 (permalink)  
Antiguo 02/07/2002, 11:44
 
Fecha de Ingreso: julio-2002
Mensajes: 5
Antigüedad: 15 años, 5 meses
Puntos: 0
No hay paso de variables!! AYUDA!

Saludos, instale IIS 4 en mi maquina, y sobre ella la version 4.2.1 de PHP, y ya logre que funcione, pero tengo un problema, cuando envio variables de un formulario a un script de PHP con metodo POST, estas variables no llegan al script , (no he hecho la prueba con GET), pero el script tambien lo tengo corriendo en otro servidor y ahi si funciona a la perfeccion, quisiera saber si habra algo que tengo que modificar en el INI de PHP o a que podra deberse este mal funcionamiento.....

Saludos : )

  #2 (permalink)  
Antiguo 02/07/2002, 12:55
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: No hay paso de variables!! AYUDA!

<offtopic>Gomo .. otra mas xD</offtopic>

Tienes que editar tu php.ini y ver el estado que tiene la directiva:
registre_globals= OFF .. si es asi .. pasala a ON

Recuerda que los Srs. de PHP nos estan mandando "mensajes" jeje como este .. para que nos acostumbremos a usar los arrays asociados de los metodos que emplees para el envio de variables a scripts PHP... me refiero a los arrays:
$_GET[] y .. $_POST[] ... siendo la manera de leerlas:
$_GET['variable'] .. o $_POST['variable'] .. segun corresponda.

Te recomiendo que para tus nuevos scripts que implemtentes uses ese metodo de acceso a tus variables, ya que es mas seguro y te evitará problemas en un futuro cuando a los srs. de PHP les de por eliminar el metodo de acceso convencinal .. y si lo deseas cambies a ON el estado de registre_globals .. para mantener compatiblidad con scripts "antigüos" ..

Un saludo,
  #3 (permalink)  
Antiguo 02/07/2002, 14:32
 
Fecha de Ingreso: julio-2002
Mensajes: 5
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: No hay paso de variables!! AYUDA!

Gracias Cluster, lo intentare de inmediato a ver que depara el destino xD....

Saludos y gracias de nuevo.
  #4 (permalink)  
Antiguo 02/07/2002, 17:56
Avatar de gomo  
Fecha de Ingreso: mayo-2002
Ubicación: [email protected]
Mensajes: 906
Antigüedad: 15 años, 7 meses
Puntos: 0
Re: No hay paso de variables!! AYUDA!

<offtopic> Definitivamente esta va al FAQ de PHP </offtopic>


<div align="center"><img src="http://cablemodem.fibertel.com.ar/sainztrapaga/images/firma.jpg" width="435" height="70" border="0">
</div>
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:07.