Foros del Web » Programando para Internet » PHP »

No me pasa las variables :(

Estas en el tema de No me pasa las variables :( en el foro de PHP en Foros del Web. Hola tengo un formulario con 8 textareas , cada una con su nombre (scrollbar1 , scrollbar2, etc, etc) y cuando la persona hace clic en ...
  #1 (permalink)  
Antiguo 28/04/2002, 18:09
 
Fecha de Ingreso: enero-2002
Mensajes: 535
Antigüedad: 15 años, 11 meses
Puntos: 1
No me pasa las variables :(

Hola
tengo un formulario con 8 textareas , cada una con su nombre (scrollbar1 , scrollbar2, etc, etc)
y cuando la persona hace clic en enviar , el resultado se muestra dentro de un iframe.
El problema es que la pagina de procesado de datos que se muestra dentro de iframe no me reemplaza la variable por el valor introducido el el textarea.
la pagina de procesado de datos tiene este codigo :

<?php
echo '
BODY { <br>
scrollbar-face-color: "$scrollbar1";<br>
scrollbar-highlight-color: "$scrollbar2";<br>
scrollbar-3dlight-color: "$scrollbar3";<br>
scrollbar-darkshadow-color: "$scrollbar4";<br>
scrollbar-shadow-color: "$scrollbar5";<br>
scrollbar-arrow-color: "$scrollbar6";<br>
scrollbar-track-color: "$scrollbar7";<br>
scrollbar-track-color: "$scrollbar8";<br>
}
<br>
</STYLE> '
?

yo lo que quiero es que reemplace "$scrollbar1" por el color que introduce la persona en el textarea
Pueden ver el formulario y el iframe donde se muestran los resultados aqui
<a href='ir.asp?http://usuarios.lycos.es/cdtedesco/barra.html' target='_blank'>http://usuarios.lycos.es/cdtedesco/barra...</a>
No se si me explique , espero que si.

Gracias desde ya :)
  #2 (permalink)  
Antiguo 28/04/2002, 18:19
Avatar de epplestun  
Fecha de Ingreso: octubre-2001
Mensajes: 1.621
Antigüedad: 16 años, 1 mes
Puntos: 5
Re: No me pasa las variables :(

normal que te encuentres con eso, si pones comillas simples ' ' el php no interpreta lo de dentro, sino que te lo escribe, en tu caso te dara la salida al navegador justo con lo k pones, por lo cual te recomiendo k uses esto otro:

echo&quot;codigo&quot;;

y cuando tengas que poner algna comilla le pones el \ para que no te marque error de sintasix.
es decir

echo&quot;hola $variable \&quot;hola\&quot;&quot;;

<table style="border:1px solid black"><tr><td><center>
<embed width="88" height="144" src="http://www.alaplaya.com/~epplestun/yo.swf"></td></td><font face=verdana size=1>Ivan Rodriguez el poder es [B]PHP</p></td></tr></table>
  #3 (permalink)  
Antiguo 28/04/2002, 18:42
 
Fecha de Ingreso: enero-2002
Mensajes: 535
Antigüedad: 15 años, 11 meses
Puntos: 1
Re: No me pasa las variables :(

Muchisimas Gracias , efectivamente era ese el problema.
  #4 (permalink)  
Antiguo 29/04/2002, 17:02
 
Fecha de Ingreso: enero-2002
Mensajes: 535
Antigüedad: 15 años, 11 meses
Puntos: 1
Re: No me pasa las variables :(

ups , nuevamente tengo otro problema:
con el codigo que les di anteriormente solo se genera el codigo , lo que quiero que haga ahora es que tambien se previsualize como va quedando en el iframe.

el codigo de el iframe lo modifique para que se pueda previsualizar pero hay algo que estoy haciendo mal y no se que es , les dejo el codigo a ver si me pueden ayudar:

codigo de la pagina de procesamiento que se muestra dentro del &lt;iframe&gt;:

&lt;html&gt;
&lt;head&gt;
&lt;?
&lt;style type=&quot;text/css&quot;&gt;
BODY {
scrollbar-face-color: $scrollbar1;
scrollbar-highlight-color: $scrollbar2;
scrollbar-3dlight-color: $scrollbar3;
scrollbar-darkshadow-color: $scrollbar4;
scrollbar-shadow-color: $scrollbar5;
scrollbar-arrow-color: $scrollbar6;
scrollbar-track-color: $scrollbar7;
}
&lt;/style&gt;;
?&gt;
&lt;/head&gt;
&lt;body bgcolor=&quot;black&quot; text=&quot;#000000&quot;&gt;
&lt;font face=&quot;tahoma&quot; color=&quot;white&quot; size=&quot;2&quot;&gt;
&lt;?php
echo &quot;
BODY {
scrollbar-face-color: $scrollbar1;
scrollbar-highlight-color: $scrollbar2;
scrollbar-3dlight-color: $scrollbar3;
scrollbar-darkshadow-color: $scrollbar4;
scrollbar-shadow-color: $scrollbar5;
scrollbar-arrow-color: $scrollbar6;
scrollbar-track-color: $scrollbar7;
}&quot;
?&gt;
&lt;/font&gt;
&lt;/body&gt;
&lt;/html&gt;

seguramente hay unas cuentas cosas que estan mal , espero que me puedan ayudar nuevamente. :)
Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:30.