Foros del Web » Programando para Internet » PHP »

No me salen los idiomas en mi web...

Estas en el tema de No me salen los idiomas en mi web... en el foro de PHP en Foros del Web. Hola, tengo una web, se llama ivanitoweb, quizás algunos ya la conozcais, pero ahora estoy trabajando en una nueva versión, y esta, esta echa modularmente, ...
  #1 (permalink)  
Antiguo 12/03/2005, 06:05
 
Fecha de Ingreso: agosto-2003
Ubicación: España
Mensajes: 202
Antigüedad: 14 años, 4 meses
Puntos: 0
No me salen los idiomas en mi web...

Hola, tengo una web, se llama ivanitoweb, quizás algunos ya la conozcais, pero ahora estoy trabajando en una nueva versión, y esta, esta echa modularmente, acepta diferentes idiomas, etcétera.
La vieja es: http://ivanitoweb.webcindario.com
la nueva: www.zeolab.com (Es un "server de pruebas")
fijense, yo, uso un sistema de includes, en localhost, me sale todo bién, pero encambio ahí no, es como si no hiciese los includes, y no da error, que puede estar pasando?
el idioma de tu navegador, lo detecta, ( arriba hize la prueba de poner Idioma: es, en o lo k sea).
Y esta es la línea de los includes:
Código PHP:
require('languages/modulos/' $modname '/' $lang_sel ".php");
require(
'languages/' $lang_sel '.php'); 
Bueno, primero usaba includes, pero pensé que era por eso, y ahora uso requires, en localhost sigue funcionando...
el sistema es, yo tengo creados los archivos en.php, es.php, ca.php, etc.
y cada uno tiene las mismas variables, con diferente valor, y luego en la pag, se piden las variables y ya esta, pero en el server zeolab.com no me enseña las variables, que puedo hacer?
adiós, gracias de antemano.

Última edición por ivanguillen; 12/03/2005 a las 06:26 Razón: Falta ortográfica
  #2 (permalink)  
Antiguo 15/03/2005, 06:30
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
pero en el server zeolab.com no me enseña las variables, que puedo hacer?
Se supone que estas variables: $modname , $lang_sel ... son externas al script? .. Es decir .. que llegan por el URL .. o por una cookie .. o una sesión? ...

Si es así .. si tu nuevo servidor usa en su configuración (phpinfo() o php.ini): register_globals a OFF .. no te va a funciona .. es decir; no vas a poder acceder a esas variables .. Deberías usar los arrays supegloblales: $_GET, $_POST .. o el método que corresponda.

En una de las primeras FAQ's se menciona el tema .. revisalo.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:03.