Foros del Web » Programando para Internet » PHP »

No me selecciona la categoria al editar

Estas en el tema de No me selecciona la categoria al editar en el foro de PHP en Foros del Web. Hola amigos: Tengo un problema, resulta que estoy haciendo un directorio de sitios webs y tengo una base de datos con dos tablas: Sitios CREATE ...
  #1 (permalink)  
Antiguo 06/12/2005, 08:37
 
Fecha de Ingreso: diciembre-2004
Mensajes: 103
Antigüedad: 13 años
Puntos: 0
No me selecciona la categoria al editar

Hola amigos:
Tengo un problema, resulta que estoy haciendo un directorio de sitios webs y tengo una base de datos con dos tablas:

Sitios

CREATE TABLE `sitios` (
`id_sitio` INT( 5 ) NOT NULL AUTO_INCREMENT ,
`descripcion` VARCHAR( 255 ) NOT NULL ,
`titulo` VARCHAR( 50 ) NOT NULL ,
`keywords` VARCHAR( 255 ) NOT NULL ,
`web_site` VARCHAR( 50 ) NOT NULL ,
`cod_tipo_sitio` INT( 2 ) NOT NULL ,
PRIMARY KEY ( `id_sitio` ) ,
INDEX ( `cod_tipo_sitio` )
);

y las categorias:

CREATE TABLE `tipo_sitios` (
`id_tipo_sitio` INT( 2 ) NOT NULL AUTO_INCREMENT ,
`desc_tipo_sitio` VARCHAR( 100 ) NOT NULL ,
PRIMARY KEY ( `id_tipo_sitio` )
);

Anda todo perfecto pero al editar, en la lista desplegable donde aparecen todas las categorias se muestra la primera, no me selecciona la que corresponde, es decir me aparece la primera de la lista y no la que subi, cosa que siempre tengo que cambiar por la que corresponde....he aqui el codigo a ver si queda mas claro...

<select size="1" name="cod_tipo_sitio">
<?

// Muestro todos los tipos de sitios para armar la lista desplegable
while($myrow_tipos = mysql_fetch_array($result_tipos))
{
if ($myrow_tipos[id_tipo_sitio] ==
$myrow[cod_tipo_sitio])
{
echo "<option value=$myrow_tipos[id_tipo_sitio]
select>$myrow_tipos[desc_tipo_sitio]</option>";
}
else
{
echo "<option value=$myrow_tipos[id_tipo_sitio]>$myrow_tipos[desc_tipo_sitio]</option>";
}
}
?>
</select>
  #2 (permalink)  
Antiguo 06/12/2005, 09:32
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
hola eximer

Creo que el error está aquí:

echo "<option value=$myrow_tipos[id_tipo_sitio]
selected>$myrow_tipos[desc_tipo_sitio]</option>";

Saludos,
  #3 (permalink)  
Antiguo 06/12/2005, 09:58
 
Fecha de Ingreso: diciembre-2004
Mensajes: 103
Antigüedad: 13 años
Puntos: 0
Exacto!!!

Gracias Amigo!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:16.