Foros del Web » Programando para Internet » PHP »

[SOLUCIONADO] Oracle y PHP 5.6.3

Estas en el tema de Oracle y PHP 5.6.3 en el foro de PHP en Foros del Web. Buenas tardes. Tengo una aplicación en PHP funcionando con una base de datos en ORACLE 11g. La misma me funcionaba con la versión 1.8.2 del ...
  #1 (permalink)  
Antiguo 22/04/2015, 14:02
 
Fecha de Ingreso: abril-2015
Mensajes: 7
Antigüedad: 7 años, 2 meses
Puntos: 0
Exclamación Oracle y PHP 5.6.3

Buenas tardes.

Tengo una aplicación en PHP funcionando con una base de datos en ORACLE 11g.

La misma me funcionaba con la versión 1.8.2 del XAMPP.

Recientemente, por un tema técnico de la empresa donde trabajo, actualizamos el XAMPP a la versión 5.6.3 (que tiene la versión de PHP con dicho número).

Estuve intentando ejecutar la aplicación, y cada vez que tiene que transaccionar con la BD, tira el siguiente error:

Código:
Fatal error: Call to undefined function oci_connect()
Ya busqué información por todos lados y no pude encontrar nada que solucione mi problema.

Activé las extensiones dentro del archivo PHP.INI que corresponden al oci8.

Noté que en esta nueva versión de PHP, solo hay una dll de "oci", que pertenece a oracle 12c. Esto es muy extraño ya que ni si quiera está mapeada en el PHP.INI.

Ya no sé más que hacer....

Alguno tuvo este mismo problema?

De antemano les agradezco mucho por su ayuda!!

Saludos
  #2 (permalink)  
Antiguo 23/04/2015, 01:48
Avatar de lauser
Moderator Unix/Linux
 
Fecha de Ingreso: julio-2013
Ubicación: Odessa (Ukrania)
Mensajes: 3.278
Antigüedad: 9 años
Puntos: 401
Respuesta: Oracle y PHP 5.6.3

Un problema similar.--> aquí.
__________________
Los usuarios que te responden, lo hacen altruistamente y sin ánimo de lucro con el único fin de ayudarte. Se paciente y agradecido.
-SOLOLINUX-
  #3 (permalink)  
Antiguo 23/04/2015, 08:04
 
Fecha de Ingreso: abril-2015
Mensajes: 7
Antigüedad: 7 años, 2 meses
Puntos: 0
Respuesta: Oracle y PHP 5.6.3

Cita:
Iniciado por lauser Ver Mensaje
Un problema similar.--> [URL="http://stackoverflow.com/questions/29009665/how-to-enable-oci-in-xampp-5-6-3"]aquí.[/URL]
Muchas gracias!!!

Ese post me solucionó el problema que me estaba volviendo loco!!!

Saludos
  #4 (permalink)  
Antiguo 23/04/2015, 09:03
 
Fecha de Ingreso: abril-2015
Mensajes: 7
Antigüedad: 7 años, 2 meses
Puntos: 0
Respuesta: Oracle y PHP 5.6.3

Les dejo un comentario de como solucioné el problema.

Instalé el nuevo XAMPP 5.6.8, que contiene la versión PHP con el mismo número. Descomneté la extensión oci8_11g y le cambie el 11g por 12c.

Luego instalé el cliente oracle 12c y voilá!!
  #5 (permalink)  
Antiguo 23/04/2015, 09:52
Avatar de lauser
Moderator Unix/Linux
 
Fecha de Ingreso: julio-2013
Ubicación: Odessa (Ukrania)
Mensajes: 3.278
Antigüedad: 9 años
Puntos: 401
Respuesta: Oracle y PHP 5.6.3

Cita:
Iniciado por agustinvazquez Ver Mensaje
Muchas gracias!!!

Ese post me solucionó el problema que me estaba volviendo loco!!!

Saludos
Me alegro...
__________________
Los usuarios que te responden, lo hacen altruistamente y sin ánimo de lucro con el único fin de ayudarte. Se paciente y agradecido.
-SOLOLINUX-

Etiquetas: 11g, apache, oracle, xampp
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:21.