Foros del Web » Programando para Internet » PHP »

Otra ayuda...

Estas en el tema de Otra ayuda... en el foro de PHP en Foros del Web. Buenas de nuevo a todos, He estado haciendo una aplicación, y para comprobar que funcionaba tambien en el servidor, la he subido en concreto a ...
  #1 (permalink)  
Antiguo 13/06/2006, 12:04
 
Fecha de Ingreso: abril-2002
Mensajes: 103
Antigüedad: 15 años, 7 meses
Puntos: 1
Otra ayuda...

Buenas de nuevo a todos,

He estado haciendo una aplicación, y para comprobar que funcionaba tambien en el servidor, la he subido en concreto a miarroba, y cuando lo he colgado todo cambiando los datos de conexion de mysql...
Me da un error que mientras lo pruebo en mi pc no lo da.
En concreto en la linea que marco..

aqui abro la sesion, pongo el include a la conexion..


$link = Conectarse();
$sSQL = "SELECT usuaris.IdClient, usuaris.IdDelegacio, Clients.NomClient, usuaris.NomUsuari, usuaris.Contrasenya FROM usuaris INNER JOIN Clients ON usuaris.IdClient = Clients.IdClient WHERE (((usuaris.NomUsuari)='$login') AND ((usuaris.Contrasenya)='$password'))";


$result=mysql_query($sSQL,$link);
if($row=mysql_fetch_array($result))
{
$IdClient=$row['IdClient'];
$NomClient=$row['NomClient'];


El error que me da es el siguiente:

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/webcindario/sbd/validacio.php on line 37.

No se la diferencia que puede haber, ya que como os explico, en local si funciona.

Un saludo y gracias
Xavi
  #2 (permalink)  
Antiguo 13/06/2006, 12:16
Avatar de mauled  
Fecha de Ingreso: marzo-2005
Ubicación: Cd. de México.
Mensajes: 3.001
Antigüedad: 12 años, 9 meses
Puntos: 33
De acuerdo

Esto sucede puesto que ocurrio un error en el query o bien no se obtuvo ningun resultado.

Modifica lo siguiente

Código PHP:
<?
$result
=mysql_query($sSQL)or die(mysql_error());
?>
He indicanos si tuviste un error, y que error te arrojo.

Saludillos.
  #3 (permalink)  
Antiguo 14/06/2006, 16:45
 
Fecha de Ingreso: abril-2002
Mensajes: 103
Antigüedad: 15 años, 7 meses
Puntos: 1
Hola de nuevo,

Ya he encontrado el error, al hacer la select, tenia los nombres de las tablas en mayusculas, mientras en mysql estaban en minuscula, por lo visto al hacerlo en mi pc, no daba error...

Pero ya esta solucionado..

Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:02.