Foros del Web » Programando para Internet » PHP »

Permissos

Estas en el tema de Permissos en el foro de PHP en Foros del Web. Buenas, tengo un script con el cual intento abrir archivos que estan por debajo del direcctorio desde el que se ejecuta. El caso esque me ...
  #1 (permalink)  
Antiguo 17/03/2003, 12:32
Avatar de kaslierx  
Fecha de Ingreso: febrero-2003
Ubicación: Valencia
Mensajes: 190
Antigüedad: 14 años, 10 meses
Puntos: 0
Permissos

Buenas, tengo un script con el cual intento abrir archivos que estan por debajo del direcctorio desde el que se ejecuta. El caso esque me da el siguiente error:

Warning: fopen(/home/cyberta/etc/cybertatu.net/passwd) [function.fopen]: failed to create stream: Permission denied in /home/cyberta/public_html/usuarios/mail.conf.php on line 23

Lo que primero piensa uno cuando ve este error es en los permisos. Pues bien los cambie a 666 y seguia sin funcionar luego los cambie a 777 y tampoco. ya no se que puede ser.

Quizas porque el archivo esta por debajo del direcctorio de la web.
La web esta en /home/cyberta/public_html/
Y el archivo en (home/cyberta/etc/

¿Que puede pasar?

Gracias
  #2 (permalink)  
Antiguo 17/03/2003, 12:57
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Le estas dando permisos de escritura a ese archivo mail.conf.php .. o al directorio? ..

De todas formas un 666 (o en octal 0666) debería sobra para permisos de escritura a ese archivo.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 17/03/2003, 13:09
Avatar de kamezen  
Fecha de Ingreso: junio-2001
Ubicación: México, D.F.
Mensajes: 128
Antigüedad: 16 años, 6 meses
Puntos: 0
si no te funciona puedes probar con la ruta !!!

tu web esta en /home/cyberta/public_html/
Y el archivo en (home/cyberta/etc/

prueba el fopen con ../etc/archivo

saludos !!

__________________
No esperes a que tu Nación haga algo por ti !!! Mejor haz primero algo por tu Nación !!!
México-WEB
  #4 (permalink)  
Antiguo 17/03/2003, 13:45
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Mira si tienes el safe_mode activo.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #5 (permalink)  
Antiguo 18/03/2003, 04:15
 
Fecha de Ingreso: febrero-2002
Ubicación: ¿donde vivo? pues en mi casa, ¿donde voy a vivir?...
Mensajes: 214
Antigüedad: 15 años, 9 meses
Puntos: 0
el safe mode no es, pq lo diria...
al menos en teoria.

lo q yo me pregunto es pq 666 y 777...
man chmod...

pq eso tiene pinta de mala administracion del *ix, nada q ver con php.
__________________
Linux, es para los que odian Microsoft/Windows, BSD, es para los que amamos *IX.
  #6 (permalink)  
Antiguo 18/03/2003, 11:53
Avatar de kaslierx  
Fecha de Ingreso: febrero-2003
Ubicación: Valencia
Mensajes: 190
Antigüedad: 14 años, 10 meses
Puntos: 0
Wenas.
Lo primero quiero agradecer a todos su colaboracion.

Respondo a todas las respuestas:

Cluster:
Los permisos se los doy al archivo que quiero abrir, el archivo es: passwd y se situa en /home/cybertatu/etc/cybertatu.net/passwd

kamezen:
no he probado a ponerlo como me has dicho, pero dudo que sea el problema ya que bajo Windows en mi ordenador si me funciona.

NeBeRuS:
¿Que es *ix? como se podria solucionar o saber si es un error de administración?

El script lo he probado bajo Windows en mi ordenador, el error me lo da al probarlo en mi servidor que es Linux.

Gracias
  #7 (permalink)  
Antiguo 18/03/2003, 15:41
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Prueba a ponerle los permisos a los directorios y subdirectorios, desde etc y a el tambien.

El *ix es la forma de referirse a los sitemas Unix y parientes (linux, freeBSD, openBSD y algun otro).

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #8 (permalink)  
Antiguo 18/03/2003, 17:51
Avatar de kaslierx  
Fecha de Ingreso: febrero-2003
Ubicación: Valencia
Mensajes: 190
Antigüedad: 14 años, 10 meses
Puntos: 0
Gracias josemi parace que ya funciona.
Probe con lo de cambiar los permisos de los direcctorios y ya funciona. Gracias tambien por aclararme lo de *ix.

Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:49.