Foros del Web » Programando para Internet » PHP »

php 4.2.2 y GD 2.0 con Red Hat 9.0

Estas en el tema de php 4.2.2 y GD 2.0 con Red Hat 9.0 en el foro de PHP en Foros del Web. Buenas Tardes: Verán, resulta que yo tengo en mi SO Red Hat 9.0 Instalado el PHP 4.2.2 y las librerias GD 1.8, y claro, entonces ...
  #1 (permalink)  
Antiguo 20/12/2004, 10:04
 
Fecha de Ingreso: junio-2003
Ubicación: Asturias
Mensajes: 2.427
Antigüedad: 14 años, 6 meses
Puntos: 7
php 4.2.2 y GD 2.0 con Red Hat 9.0

Buenas Tardes:

Verán, resulta que yo tengo en mi SO Red Hat 9.0 Instalado el PHP 4.2.2 y las librerias GD 1.8, y claro, entonces hay funciones como:

imagecopyresampled():
imagecreatetruecolor():

Que no me funcionan, probé a descargarme un .rpm de las librerias Gd2 que había por ahi, pero entonces me fallaba la llamada al módulo libphp4.so.

¿Alguien sabe como podría hacer para conseguir actualizar mi Libreria Gd 1.8 a la Gd 2.0? ¿O a la Gd 2.33?
__________________
Charlie.
  #2 (permalink)  
Antiguo 20/12/2004, 10:11
Avatar de lado2mx
Colaborador
 
Fecha de Ingreso: agosto-2001
Ubicación: Veracruz
Mensajes: 3.720
Antigüedad: 16 años, 4 meses
Puntos: 9
instala las versiones GD 2.0 en adelante, ya que ahí tienen las versiones para esas dos instrucciones en PHP.

Esas versiones que pides están disponibles en las extensiones de la página de PHP.net.

Última edición por lado2mx; 20/12/2004 a las 10:12
  #3 (permalink)  
Antiguo 20/12/2004, 10:14
 
Fecha de Ingreso: junio-2003
Ubicación: Asturias
Mensajes: 2.427
Antigüedad: 14 años, 6 meses
Puntos: 7
Ya lo sé, pero si te fijas en el POST que he puesto:


" probé a descargarme un .rpm de las librerias Gd2 que había por ahi, pero entonces me fallaba la llamada al módulo libphp4.so. "

Si alguien sabría decirme como hacer la transición de Gd 1.8 a Gd 2.0 le estaría muy agradecido.
__________________
Charlie.
  #4 (permalink)  
Antiguo 20/12/2004, 17:55
 
Fecha de Ingreso: julio-2004
Ubicación: Arg. Neuquén
Mensajes: 44
Antigüedad: 13 años, 5 meses
Puntos: 0
php 4.2.2 y GD 2.0 con Red Hat 9.0

no pudés usar funciones de gd2.0 teniendo gd1.8 y otra cosa
nunca podrás usar las gd2.0 con php 4.2.2

actualiza a la versión de tu php por lo menos a 4.3.2

si no no podrás usar funciones como imagecreatetruecolor():
que te hacen los mejores thumbs
  #5 (permalink)  
Antiguo 21/12/2004, 03:48
 
Fecha de Ingreso: junio-2003
Ubicación: Asturias
Mensajes: 2.427
Antigüedad: 14 años, 6 meses
Puntos: 7
Ok, sabes de algún sitio donde pueda bajarme el php-4.3.2.rpm y el gd2.rpm ? No me gustaría tener que compilar.
__________________
Charlie.
  #6 (permalink)  
Antiguo 21/12/2004, 08:12
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
www.rpmfind.net

Un saludo,
  #7 (permalink)  
Antiguo 21/12/2004, 08:54
 
Fecha de Ingreso: junio-2003
Ubicación: Asturias
Mensajes: 2.427
Antigüedad: 14 años, 6 meses
Puntos: 7
Gracias cluster, pero ahi nun está el php-4.3 ni las gd2 para Red Hat 9.0, ya había mirado ahi y con el apt-get.

De todas formas gracias.
__________________
Charlie.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:56.