Foros del Web » Programando para Internet » PHP »

PHP 4.3.1 problemas

Estas en el tema de PHP 4.3.1 problemas en el foro de PHP en Foros del Web. Hola a [email protected]: En mi equipo, localhost, tenía instalado el php 4.0.2 y algunos scripts no hacían nada, ni daban mensajes de error. Al subirlos ...
  #1 (permalink)  
Antiguo 22/03/2003, 17:20
 
Fecha de Ingreso: abril-2002
Mensajes: 17
Antigüedad: 15 años, 7 meses
Puntos: 0
PHP 4.3.1 problemas

Hola a [email protected]:

En mi equipo, localhost, tenía instalado el php 4.0.2 y algunos scripts no hacían nada, ni daban mensajes de error.
Al subirlos al server con php 4.1.2 funcionaban correctamente.
Ahora he instalado la 4.3.1 y todo lo que no funcionaba si lo hace ahora. Pero...
Tengo un script que usa mysql para encuestas, pollphp, y ahora este script da un error:
Fatal error: Cannot redeclare set_max_bar_length() in \home\sites\site11\web\pollphp\textfile\include\cl ass_poll.php on line 116
Alguién puede decirme como solucionar este problema?
Gracias y saludos.

QchiQchy

Solucionado: Cambiando el nombre a la función.

Última edición por QchiQchy; 22/03/2003 a las 19:03
  #2 (permalink)  
Antiguo 22/03/2003, 17:33
 
Fecha de Ingreso: diciembre-2002
Mensajes: 341
Antigüedad: 15 años
Puntos: 0
Lo más probable es que en este script que dices, "poll.php", hallas incluido dos veces el script "class_poll.php".

Y por eso, la segunda vez que lo incluyes te da un error diciendo que no puede redeclarar una de las funciones de dicho script, que si no me equivoco será la primera función del script en cestión, "class_poll.php".

Un saludo
__________________
guebs - alojamiento web y dominios
www.guebs.com
blog.guebs.com
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:42.