Foros del Web » Programando para Internet » PHP »

PHP 5.0.0 Beta 1

Estas en el tema de PHP 5.0.0 Beta 1 en el foro de PHP en Foros del Web. Al fin salio la tan deseada PHP5, la primera version beta. Pueden descargala desde www.php.net. Los cambios pueden verlos en: http://www.php.net/ChangeLog-5.php Y lo nuevo de ...

  #1 (permalink)  
Antiguo 29/06/2003, 14:34
Avatar de epplestun  
Fecha de Ingreso: octubre-2001
Mensajes: 1.621
Antigüedad: 16 años, 1 mes
Puntos: 5
PHP 5.0.0 Beta 1

Al fin salio la tan deseada PHP5, la primera version beta. Pueden descargala desde www.php.net.

Los cambios pueden verlos en:

http://www.php.net/ChangeLog-5.php

Y lo nuevo de Zend Engine 2 en:

http://www.php.net/zend-engine-2.php

Espero que la disfruten tanto como yo
__________________
Usuario registrado de Linux #288725
  #2 (permalink)  
Antiguo 29/06/2003, 14:38
V_G
Invitado
 
Mensajes: n/a
Puntos:
Gracias por los enlaces Epplestun. Voy de cabeza a bajármelo ....
  #3 (permalink)  
Antiguo 29/06/2003, 15:51
Avatar de Webstudio
Colaborador
 
Fecha de Ingreso: noviembre-2001
Ubicación: 127.0.0.1
Mensajes: 3.499
Antigüedad: 16 años
Puntos: 68
Excelente noticia!
ya bajado e instalado.Ahora a probar Todas las funcionalidades nuevas para continuar con la segunda parte del tutorial sobre las novedades!
Gracias por el Dato Epples, siempre atento a las listas.
__________________
Tutoriales Photoshop | Web-Studio.com.ar
Artículos PHP | ZonaPHP.com
  #4 (permalink)  
Antiguo 29/06/2003, 17:02
Avatar de Creature  
Fecha de Ingreso: junio-2003
Ubicación: localhost
Mensajes: 19
Antigüedad: 14 años, 5 meses
Puntos: 0
Genial!

Habia leido tantos adelantos del PHP5 q ya mismo quiero probarlo.

Duduru ... // Esperando a que descargue . . . . .
__________________
Gritale al cielo que no, quieres ser solo uno más ...
  #5 (permalink)  
Antiguo 30/06/2003, 04:25
Avatar de ferny
Il capo della mafia
 
Fecha de Ingreso: febrero-2002
Ubicación: Al final del cable
Mensajes: 10.080
Antigüedad: 15 años, 9 meses
Puntos: 54
¡¡¡A por él!!!
__________________
www.mundodivx.com || www.mundodivx.org

Pon tu mano en un horno caliente durante un minuto y te parecerá una hora.
Siéntate junto a una chica preciosa durante una hora y te parecerá un minuto.
Eso es la relatividad.
  #6 (permalink)  
Antiguo 30/06/2003, 08:09
Avatar de ferny
Il capo della mafia
 
Fecha de Ingreso: febrero-2002
Ubicación: Al final del cable
Mensajes: 10.080
Antigüedad: 15 años, 9 meses
Puntos: 54
Ya está aquí el primer error
Al tratar de instalar este PHP, lo hago como venía haciéndolo hasta ahora. Quito el anterior, meto el nuevo php.ini (una vez lo he configurado) y el nuevo php4ts.dll, pero en vez de salirme lo que debería, de "PHP 5.0.0 running...", me sale:
Cita:
Syntax error on line 177 of c:/archivos de programa/apache group/apache/conf/httpd.conf
Cannot load c:/php/sapi/php4apache.dll into server: (126) No se puede encontrar el módulo especificado

Note the error or messages above, and press the <ESC> key to exit.
Y a los 30 segundos se corta. Si vuelvo a poner el php.ini y el php4ts.dll antiguos (versión 4.3.2) vuelve a funcionar (no hice ningún cambio en el httpd.conf del apache 1.3.27 que tengo), siendo todas las rutas las mismas. Demasiado extraño.

¿Qué podrá ser?
__________________
www.mundodivx.com || www.mundodivx.org

Pon tu mano en un horno caliente durante un minuto y te parecerá una hora.
Siéntate junto a una chica preciosa durante una hora y te parecerá un minuto.
Eso es la relatividad.
  #7 (permalink)  
Antiguo 30/06/2003, 08:10
Avatar de epplestun  
Fecha de Ingreso: octubre-2001
Mensajes: 1.621
Antigüedad: 16 años, 1 mes
Puntos: 5
JEJEJ recuerda k no es php4 sino php5 , aun que bueno yo con php5-dev lo tengo rulando jejej nose .... remitelo a bugs.php.net
__________________
Usuario registrado de Linux #288725
  #8 (permalink)  
Antiguo 30/06/2003, 08:16
Avatar de ferny
Il capo della mafia
 
Fecha de Ingreso: febrero-2002
Ubicación: Al final del cable
Mensajes: 10.080
Antigüedad: 15 años, 9 meses
Puntos: 54
Ya, pero aun siendo PHP5, los dll de la carpeta sapi se llaman todos php4xxxxx.dll como el ya citado php4apache.dll (que, por cierto, ocupa lo mismo que el que venía con la 4.3.2, 28672 bytes )
Esperaré a ver si alguien sabe el motivo
__________________
www.mundodivx.com || www.mundodivx.org

Pon tu mano en un horno caliente durante un minuto y te parecerá una hora.
Siéntate junto a una chica preciosa durante una hora y te parecerá un minuto.
Eso es la relatividad.
  #9 (permalink)  
Antiguo 30/06/2003, 21:17
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
ferny .. editate el httpd.conf con tu editor PHP que te numerre líneas y peganos la línea del error ...

Tal vez no use PHP 5.0.0 .. el AddModule mod_php4.c (si mal no recuerdo al instalar PHP 4.x sobre Apache 2 hace tiempo me soltó un error similar .. comenté dicha línea y a correr xDDD) pruebalo y nos comentas.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #10 (permalink)  
Antiguo 30/06/2003, 21:29
Avatar de camargo  
Fecha de Ingreso: abril-2002
Ubicación: Kerétaro, Méjiko
Mensajes: 1.045
Antigüedad: 15 años, 8 meses
Puntos: 2
Yo generalmente nunca trabajo desde mi ordenador, pss casi siempre estoy online y todo lo subo a mi serv,, pss he leido sobre dificultades al instalarlo en plataforma windows xp,, kisiera saber un poco sobre la instalacion de PHP, MYSQL, y claro APACHE en sus versiones mas recientes y que es lo que se debe configurar o mover para tener un rendimiento optimo en mi ordenata

Salu2
__________________
http://www.chorcha.com
  #11 (permalink)  
Antiguo 01/07/2003, 08:41
Avatar de Webstudio
Colaborador
 
Fecha de Ingreso: noviembre-2001
Ubicación: 127.0.0.1
Mensajes: 3.499
Antigüedad: 16 años
Puntos: 68
Ferny, yo lo bajé, tuve algunos problemitas, no lo niego, pero anda que una visita al NewsGroup php.install no solucionara.
"No aclares que amanece" dice un dicho por estos lados. Bueno, hagamos amanecer :

Primero, el nombre del Dll para apache, no se llama php4xxxxxxx.dll porque sea la versión para php4, sino que es un "juego" que se hace con el inglés, si reemplazas el 4 por su nombre en inglés, te queda "PHP four APache" lo que suena igual a "PHP for Apache" (PHP para Apache). Pero no se preocupen, la misma preocupación le surgió a mucha gente, incluso de habla inglesa.

Segundo, tema instalación. Lo primero que hice fue probar "lo tipico":
Código:
LoadModule php4_module c:\php5\sapi\php4apache2.dll
AddType application/x-httpd-php .php
Y claro, no funcionó. Lo primero instintivamente que probé, fue cambiar el php4_* por php5_, pero tampoco. Finalmente pude hacerlo funcionar, moviendo el archivo iconv.dll que está en el directorio /dlls al directorio /sapi. Con eso mi PHP5 Beta 1 funcionó perfectamente.
__________________
Tutoriales Photoshop | Web-Studio.com.ar
Artículos PHP | ZonaPHP.com
  #12 (permalink)  
Antiguo 01/07/2003, 08:55
Avatar de epplestun  
Fecha de Ingreso: octubre-2001
Mensajes: 1.621
Antigüedad: 16 años, 1 mes
Puntos: 5
Una cosita mas, no intenten trabajar con mysql y php5 ya que el binario para windows no trae la libreria php_mysql.dll puede que haya sido un bug a la hora de compilarlo o no jeje pero si no le sfuncionan no se alteren
__________________
Usuario registrado de Linux #288725
  #13 (permalink)  
Antiguo 01/07/2003, 10:34
Avatar de Webstudio
Colaborador
 
Fecha de Ingreso: noviembre-2001
Ubicación: 127.0.0.1
Mensajes: 3.499
Antigüedad: 16 años
Puntos: 68
No, esto en realidad no es un Bug, sino un adesicion tomada basados en el cambio de la licencia de MySQL. Ahora mismo entro en una reunión, pero cuando vengo, intentaré explicarlo un poco.
__________________
Tutoriales Photoshop | Web-Studio.com.ar
Artículos PHP | ZonaPHP.com
  #14 (permalink)  
Antiguo 01/07/2003, 10:52
Avatar de epplestun  
Fecha de Ingreso: octubre-2001
Mensajes: 1.621
Antigüedad: 16 años, 1 mes
Puntos: 5
Na si la discusion esa ya me la se :) por temas de licencias de mysql el grupo de php a decidido no adaptarla, pero a caso MS SQL no es propietaria?¿ u Oracle?¿ deberian ponerla como extension por lo menos aun que no fuera parte del CORE o no se instalase por defecto
__________________
Usuario registrado de Linux #288725
  #15 (permalink)  
Antiguo 01/07/2003, 13:51
Avatar de Webstudio
Colaborador
 
Fecha de Ingreso: noviembre-2001
Ubicación: 127.0.0.1
Mensajes: 3.499
Antigüedad: 16 años
Puntos: 68
Bueno, el "comentario" se me extendió un poco, así que aquí tienen un link hacia el mismo, pero ya en forma de artículo :

http://www.zonaphp.com/index.php?mod...ion=leer&id=28

Espero sus comentarios al respecto.
__________________
Tutoriales Photoshop | Web-Studio.com.ar
Artículos PHP | ZonaPHP.com
  #16 (permalink)  
Antiguo 02/07/2003, 04:01
Avatar de Cain  
Fecha de Ingreso: enero-2002
Ubicación: Catalunya
Mensajes: 6.459
Antigüedad: 15 años, 11 meses
Puntos: 17
Pues a mi me parece que es un gran problema para los que tenemos montones de webs realizadas con PHP contra MySQL. Afortunadamente, no es imprescindible actualizar ni PHP ni MySQL y, espero, que cuando saquen la versión estable de PHP 5 vuelva a haber soporte para MySQL.

De todos modos, he visto que se puede instalar una libreria para MySQL 3.x de forma no nativa y seguir funcionando igual. Con lo que se podría usar PHP 5 con MySQL 3x
__________________
M a l d i t o F r i k i
  #17 (permalink)  
Antiguo 02/07/2003, 04:03
Avatar de ferny
Il capo della mafia
 
Fecha de Ingreso: febrero-2002
Ubicación: Al final del cable
Mensajes: 10.080
Antigüedad: 15 años, 9 meses
Puntos: 54
Yo he intentado lo que dijo Webstudio y más, y no lo he logrado
La línea 177 del httpd.conf es, curiosamente:

LoadModule php4_module c:/php/sapi/php4apache.dll

Creo que además, viendo los mensajes superiores, me quedaré con la 4.3.2 hasta que saquen una versión definitiva
__________________
www.mundodivx.com || www.mundodivx.org

Pon tu mano en un horno caliente durante un minuto y te parecerá una hora.
Siéntate junto a una chica preciosa durante una hora y te parecerá un minuto.
Eso es la relatividad.
  #18 (permalink)  
Antiguo 02/07/2003, 04:33
Avatar de Cain  
Fecha de Ingreso: enero-2002
Ubicación: Catalunya
Mensajes: 6.459
Antigüedad: 15 años, 11 meses
Puntos: 17
Claro, las versiones de prueba son sólo para "jugar" y empezar a acostumbrarse, pero NUNCA debes subirlas a un servidor donde tengas webs funcionando.
__________________
M a l d i t o F r i k i
  #19 (permalink)  
Antiguo 02/07/2003, 04:51
Avatar de ferny
Il capo della mafia
 
Fecha de Ingreso: febrero-2002
Ubicación: Al final del cable
Mensajes: 10.080
Antigüedad: 15 años, 9 meses
Puntos: 54
Yo quería probarlo en mi ordenador local, pero me da que no voy a poder... hasta que salga una versión definitiva
__________________
www.mundodivx.com || www.mundodivx.org

Pon tu mano en un horno caliente durante un minuto y te parecerá una hora.
Siéntate junto a una chica preciosa durante una hora y te parecerá un minuto.
Eso es la relatividad.
  #20 (permalink)  
Antiguo 02/07/2003, 09:04
Avatar de Webstudio
Colaborador
 
Fecha de Ingreso: noviembre-2001
Ubicación: 127.0.0.1
Mensajes: 3.499
Antigüedad: 16 años
Puntos: 68
FErny, leiste mi consejo del php5_* ? finalmente debe quedar asi. No te rindas ante el primer traspié, si yo lo hubiera hecho no estaria probando ahora PHP5.
Saludos.
__________________
Tutoriales Photoshop | Web-Studio.com.ar
Artículos PHP | ZonaPHP.com
  #21 (permalink)  
Antiguo 02/07/2003, 10:40
Avatar de ferny
Il capo della mafia
 
Fecha de Ingreso: febrero-2002
Ubicación: Al final del cable
Mensajes: 10.080
Antigüedad: 15 años, 9 meses
Puntos: 54
Vamos a ver, ¿entonces qué he de hacer? ¿cambiar el nombre de archivo de php4_* a php5_* y luego copiar el iconv.dll a la carpeta sapi? ¿algo más?
__________________
www.mundodivx.com || www.mundodivx.org

Pon tu mano en un horno caliente durante un minuto y te parecerá una hora.
Siéntate junto a una chica preciosa durante una hora y te parecerá un minuto.
Eso es la relatividad.
  #22 (permalink)  
Antiguo 02/07/2003, 13:48
Avatar de Webstudio
Colaborador
 
Fecha de Ingreso: noviembre-2001
Ubicación: 127.0.0.1
Mensajes: 3.499
Antigüedad: 16 años
Puntos: 68
con eso a mi me funcionó.
__________________
Tutoriales Photoshop | Web-Studio.com.ar
Artículos PHP | ZonaPHP.com
  #23 (permalink)  
Antiguo 02/07/2003, 15:09
Avatar de ferny
Il capo della mafia
 
Fecha de Ingreso: febrero-2002
Ubicación: Al final del cable
Mensajes: 10.080
Antigüedad: 15 años, 9 meses
Puntos: 54
Na, no hay manera... sigue marcando el mismo error. Por probar que no quede, estuve más de una hora probando configuraciones distintas, modificando todo lo modificable y siempre el mismo error.

Definitivamente me rindo, seguiré de momento con la 4.3.2 que me va perfectamente

Gracias
__________________
www.mundodivx.com || www.mundodivx.org

Pon tu mano en un horno caliente durante un minuto y te parecerá una hora.
Siéntate junto a una chica preciosa durante una hora y te parecerá un minuto.
Eso es la relatividad.
  #24 (permalink)  
Antiguo 02/07/2003, 15:56
Avatar de Manoloweb  
Fecha de Ingreso: enero-2002
Ubicación: Monterrey
Mensajes: 2.454
Antigüedad: 15 años, 10 meses
Puntos: 5
Pues yo acabo de ver en la documentación, con muy tristes ojos, que la librería de MySQL no va a integrarse en la nueva versión. En cambio tendremos acceso a SQLite...

Entré al sitio de SQLite y me ha parecido una reverenda basura.

Aun que tiene algunas funciones que siempre hemos pedido de MySQL, como las transacciones o los triggers, tiene también algunas cosas que a mi no me han gustado nada...

a) Campos "uniformato", es decir, aunque definas un campo como INT, te permite meterle texto, punto flotante o cualquier otro tipo de dato (de hecho TODO lo interpreta como texto)

b) No tiene ALTER TABLE, si quieres modificarle algo a tu tabla, debes borrarla y crearla de nuevo.

c) No hay un manual completo, solo unas cuantas FAQ y unas listas de correo

d) Su web site parece de primaria... no te inspira NADA de confianza

e) Su librería API parece MUUUUYYY limitada a simple vista

f) Hasta ahora no hay servidores host que la tengan instalada


Que han pensado los de PHP???

__________________
Manoloweb
  #25 (permalink)  
Antiguo 02/07/2003, 16:23
Nok
 
Fecha de Ingreso: abril-2001
Mensajes: 302
Antigüedad: 16 años, 7 meses
Puntos: 0
Manoloweb, si bien SQLite no es un motor demasiado potente como mysql, la "culpa" no es de la gente de php, mas bien es una incompatibilidad de licencias entre php y mysql.
Para mas info te recomiendo este enlace:

http://www.zonaphp.com/index.php?mod...ion=leer&id=28

Otro tema que al parecer no queda claro, es que SQLite no es obligatorio su uso, es decir es una base de datos mas que soporta php, no hay porque utilizarla.

Saludos
Nok.
  #26 (permalink)  
Antiguo 03/07/2003, 02:16
Avatar de epplestun  
Fecha de Ingreso: octubre-2001
Mensajes: 1.621
Antigüedad: 16 años, 1 mes
Puntos: 5
SQLite es bastante mas potente para aplicaciones medianas y pequeñas que MySQL y no necesita de un servidor de base de datos
__________________
Usuario registrado de Linux #288725
  #27 (permalink)  
Antiguo 03/07/2003, 02:18
Avatar de epplestun  
Fecha de Ingreso: octubre-2001
Mensajes: 1.621
Antigüedad: 16 años, 1 mes
Puntos: 5
Por cierto ferny tienes las solucion de tu problema en:

http://bugs.php.net/bug.php?id=24397

__________________
Usuario registrado de Linux #288725
  #28 (permalink)  
Antiguo 03/07/2003, 02:49
Avatar de ferny
Il capo della mafia
 
Fecha de Ingreso: febrero-2002
Ubicación: Al final del cable
Mensajes: 10.080
Antigüedad: 15 años, 9 meses
Puntos: 54
Bien, ahora sí. Cuento los pasos:

- httpd.conf: usar estas lineas:

LoadModule php5_module c:/php/sapi/php5apache.dll
AddModule mod_php5.c

- Cambiar el nombre de php4apache.dll a php5apache.dll

- Añadir el iconv.dll de la carpeta dlls a la carpeta sapi

Ahora lo que hace es, al arrancar el apache, se corta al instante, lo vuelvo a arrancar y ya funciona.

Lo malo, obviamente, no funciona mysql.

Conclusión: ya lo he desinstalado Necesito mysql.

¡Mier**! Tanto esfuerzo...

Mil gracias
__________________
www.mundodivx.com || www.mundodivx.org

Pon tu mano en un horno caliente durante un minuto y te parecerá una hora.
Siéntate junto a una chica preciosa durante una hora y te parecerá un minuto.
Eso es la relatividad.
  #29 (permalink)  
Antiguo 03/07/2003, 04:52
Avatar de epplestun  
Fecha de Ingreso: octubre-2001
Mensajes: 1.621
Antigüedad: 16 años, 1 mes
Puntos: 5
Si te descargas de http://snaps.php.net la ultima version de PHP5 tendras soporte para MySQL creo para la libreria 3.x.x no asi para la 4.1.x
__________________
Usuario registrado de Linux #288725
  #30 (permalink)  
Antiguo 03/07/2003, 07:49
Avatar de nuevo  
Fecha de Ingreso: mayo-2003
Ubicación: Spain
Mensajes: 2.009
Antigüedad: 14 años, 7 meses
Puntos: 2
creo que en el futuro mysql ya no lo podremos usar... tenemos que ir pensando ya en sus sucesores... no hay mas remedio... no creo que alguien este pensando en pasar el resto de su vida en php5 y una libreria de esas raras de mysql3.... venga... yo tengo la misma desilusion que muchos otros.... no me entra en la cabeza un cambio tan radikal... pero bueno el futuro es incierto y lo unico que sabemos hasta el momento.... que los que trabajamos con win se nos acavo el chollo de MySql....

no hace ni 20 minutos que acavo de imprimir el manual de mysql... porq.... .... .... .... ...

porcierto " epplestun ", eres un hacha con las noticias !!!
__________________
3w.valenciadjs.com
3w.laislatv.com

Última edición por nuevo; 03/07/2003 a las 07:51
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:35.