Foros del Web » Programando para Internet » PHP »

php 5 o 4? pido consejo

Estas en el tema de php 5 o 4? pido consejo en el foro de PHP en Foros del Web. Hola amigos espero que me puedan aconsejar : Tengo conocimientos basicos de PHP 4 y Mysql 4.0 Ahora bien, quiero dedicarme a hacer paginas web ...
  #1 (permalink)  
Antiguo 13/08/2006, 16:24
 
Fecha de Ingreso: julio-2005
Mensajes: 45
Antigüedad: 12 años, 4 meses
Puntos: 0
De acuerdo php 5 o 4? pido consejo

Hola amigos
espero que me puedan aconsejar :


Tengo conocimientos basicos de PHP 4 y Mysql 4.0

Ahora bien, quiero dedicarme a hacer paginas web como freelance, pero veo que los sevridores de hosting (como por ejemplo Brinkster) utilizan la version php5

Ademas me han comentado que ahora Mysql tiene tambien Procedimientos almacenados algo que no habia en la version Mysqll 4.0.

Mis pregunta son las siguientes :

- Que Servicio de Hosting me recomiendan, el que sea mas rapido y seguro:

- Que version de PHP y de Mysql utilizan ahora los proveedores de hosting y cual me recomiendan? (para empezar a programar en esas versiones)


- Que Sistema Operativo, IDE, y herramientas graficas me recomiendan utilizar?
(antes yo usaba el Zend Studio y el MysqlCOntrolCenter)


- Podrian facilitarme algunos links para descargar los instaladores




Muchas gracias de antemano
  #2 (permalink)  
Antiguo 13/08/2006, 17:01
AlvaroG
Invitado
 
Mensajes: n/a
Puntos:
Hola,

Cita:
pero veo que los sevridores de hosting (como por ejemplo Brinkster) utilizan la version php5
Pues la verdad es que muy pocos hasta ahora han cambiado a php5. Si no recuerdo mal, se calcula que solo el 5% de los proveedores han migrado.

En cuanto a alojamientos, todo dependerá del que prefieras, todos siempre tendrán sus detalles.

En cuanto a las versiones de los servidores, vale decir que las diferencias entre php4 y php5 son notorias en algunos pocos puntos, que serán más importantes dependiendo de lo que tengas que hacer. Estos puntos son:
-> Clases y Objetos (Programación Orientada a Objetos)
-> Modelo de Objetos del Documento (DOM) XML
-> Soporte de MySQL

El cambio en el soporte de MySQL se trata de que las funciones de mysql ya no están integradas 'de base' en php, sino que deben ser instaladas. De cualquier forma como programador quizás no lo notes, ya que están disponibles las mismas funciones.

En cualquier caso, siempre podés visitar el Apéndice B del manual

En lo que respecta a los servidores MySQL, solo decirte que el SQL es un lenguaje que no depende de qué base uses (en su forma más básica, por supuesto).

Y por último, decirte que el sistema operativo y programas que tenés que usar es simplemente el que te resulte más cómodo. Personalmente uso Slackware Linux 10, con Bluefish o Anjuta como editor, muchos usan Windows con Dreamweaver, otros usan el entorno Eclipse.... Todo dependerá del programa que te resulte más cómodo, en eso pocos consejos te puedo dar.


Saludos.
  #3 (permalink)  
Antiguo 13/08/2006, 17:10
 
Fecha de Ingreso: julio-2005
Mensajes: 45
Antigüedad: 12 años, 4 meses
Puntos: 0
Muchas gracias

me será de mucha ayuda

:)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:24.