Foros del Web » Programando para Internet » PHP »

PHP 5 y MySQL 5 Pregunta

Estas en el tema de PHP 5 y MySQL 5 Pregunta en el foro de PHP en Foros del Web. Hola me gustaria saber si las aplicaciones que han sido desarrolladas en PHP4 y las consultas a MySQL 4 tendrán problemas si se ejecutan en ...
  #1 (permalink)  
Antiguo 21/04/2006, 09:05
 
Fecha de Ingreso: agosto-2003
Mensajes: 398
Antigüedad: 14 años, 3 meses
Puntos: 0
PHP 5 y MySQL 5 Pregunta

Hola me gustaria saber si las aplicaciones que han sido desarrolladas en PHP4 y las consultas a MySQL 4 tendrán problemas si se ejecutan en servidores PHP5 y MySQL 5
A ver si me podeis ayudar a aclarar esta duda.
Gracias.
  #2 (permalink)  
Antiguo 21/04/2006, 10:17
Avatar de andinistas  
Fecha de Ingreso: julio-2003
Ubicación: Bogotá COL
Mensajes: 1.000
Antigüedad: 14 años, 4 meses
Puntos: 0
sip

Pues a mi me trajo algunas complicaciones al instalar el fedora 5 con Apache 2, php 5 y mysql 5.0.18, hmm mi aplicación no funcionaba correctamente especialmente en el envio de variables y era que estaba utilizando codigo que venia de la version de php 4 como por ejemplo la variable $HTTP_POST_VARS ya no servía me tocó actualizar siempre muchas líneas de código.

Con respecto a los Querys SQL pues eso varía mucho de cómo los hicistes va mucho con tu modelo de desarrollo de la bd, en mi caso ningun problema.

Venía de una mandrake linux 10.1 como server web hasta que perdio el soporte de actualizaciones y me tocó pasarme a fedora 5 que por cierto tiene mucho mayor rendimiento y es más estable.

Te recomiendo instalar en un equipo aparte el sistema de tu preferencia y poner a prueba tu aplicación.
__________________
Un Saludo, Andinistas.
"Llegaron... Ellos tenían la biblia y nosotros la tierra... y nos dijieron: 'Cierren los ojos y recen.' Cerramos los ojos y cuando los abrimos,
ellos tenían la tierra y nosotros la biblia." Abadío Green.
  #3 (permalink)  
Antiguo 21/04/2006, 10:23
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
En principio no tendras muchos problemas.

Eso sí .. PHP 5 que uses tendra que tener instalado la extensión para Mysql (php_mysql.so o php_mysql.dll según corresponda) que es la que tus aplicaciones escritas en PHP 4 para Mysql 4.x usaran ese grupo de funciones mysql_xxxx() (no sólo mysqli_xxxx() que es lo que se usa para obtener el máximo rendimiento de Mysql 5.x. Pueden convivir ambas extensiones).

Otros detalles que puedas tener se referiran a diferencias de configuración: register_globals? .. reporte de errores o "display" de los mismos .. manejo de sesiones .. etc. Pero serán problemas que se puedan resolver ajustando tu código en la mayoría de casos y en otros "forzando" cierta configuración a PHP.

Todo esto depende de tu aplicación. Lo mejor es probarla y esperar esos "mensajes de error" si los tienes.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.

Última edición por Cluster; 21/04/2006 a las 10:30
  #4 (permalink)  
Antiguo 21/04/2006, 10:28
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
la variable $HTTP_POST_VARS ya no servía me tocó actualizar siempre muchas líneas de código.
En PHP 5.x tienes una directiva para "poder" usar tu código antigüo .. se trata de:

register_long_arrays

Eso por defecto está a OFF .. es decir .. no se crean esos arrays para que usemos los "superglobales" $_POST y demás. En el php.ini hay un comentario al respecto de que hace dicha directiva.

Mi sugerencia no vá por el camino de que toques tu configuración .. sino que sepas por qué sucedía. Igualmente sigue usando las variables superglobales .. por qué a futuro no habrá forma de cambiar dicha configuración de PHP.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:43.