Foros del Web » Programando para Internet » PHP »

Php + Informix

Estas en el tema de Php + Informix en el foro de PHP en Foros del Web. Que tal. Tengo una base de datos en informix en unix Un xp server donde ejecuto el php y el apache Tengo descargada las últimas ...
  #1 (permalink)  
Antiguo 06/06/2005, 06:25
 
Fecha de Ingreso: julio-2003
Mensajes: 3
Antigüedad: 14 años, 5 meses
Puntos: 0
Php + Informix

Que tal.

Tengo una base de datos en informix en unix
Un xp server donde ejecuto el php y el apache
Tengo descargada las últimas versiones de los diferentes programas.

Realizadas las pruebas de conexion a informix via odbc desde access, funciona
Realizadas las pruebas de conexion a informix con el setcli, funciona.

Vamos que funciona todo

Realizo las pruebas de ejecucion de la aplicacion php desde el promp (entorno dos) y tambien funciona.

El caso es que cuando lo ejecuto desde I. Explorer me da el error "No se encuentra el nombre del origen de datos".

Alguien tiene idea de que puede pasar.

Gracias de antemano

Carlos M.V.
[email protected]


*****************************
*****************************
  #2 (permalink)  
Antiguo 06/06/2005, 08:53
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Si muestras tu código tal vez veamos algún detalle que se te pasó.

Un saludo,
  #3 (permalink)  
Antiguo 06/06/2005, 11:14
 
Fecha de Ingreso: julio-2003
Mensajes: 3
Antigüedad: 14 años, 5 meses
Puntos: 0
El código es el que viene en todos los ejemplos:

<html>
<body>
<?php
$conn=odbc_connect('coches','informix','informix') ;
if (!$conn)
{
exit("Conexión fallada: " . $conn);
}
$sql="SELECT * FROM marcas";
$rs=odbc_exec($conn,$sql);
odbc_close($conn);
?>
</body>
</html>
Es un ejemplo, pero como ya te comento, si funciona desde el prompt del dos: php fichero.php, es desde el explorador desde donde no funciona.

Gracias
  #4 (permalink)  
Antiguo 07/06/2005, 07:47
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Y .. PHP en general te funciona en ese servidor .. es decir .. tienes instalado PHP bajo tu servidor HTTP que uses? .. El error que obtienes es ese textual (o lo traducistes tu mismo .. o lo interpretastes ...?)

Un saludo,
  #5 (permalink)  
Antiguo 07/06/2005, 15:42
 
Fecha de Ingreso: julio-2003
Mensajes: 3
Antigüedad: 14 años, 5 meses
Puntos: 0
Los diferentes cursos, ejemplos y otros..., con mysql, access, tablas, mails, formularios..., etc, funcionan todos los ejemplos.
En cuanto al mensaje, es literal, aunque tambien me lo daba en ingles (he reinstalado diferentes versiones): unable to locate... y algo mas.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:51.