Foros del Web » Programando para Internet » PHP »

PHP y PHP4 consulta

Estas en el tema de PHP y PHP4 consulta en el foro de PHP en Foros del Web. Tengo una galeria hecha en php (a secas) y tengo un servidor con PHP4 y no me funciona...que debo hacer para que funque el asunto??? ...
  #1 (permalink)  
Antiguo 05/02/2004, 11:56
 
Fecha de Ingreso: marzo-2003
Ubicación: onde toy?
Mensajes: 1.437
Antigüedad: 14 años, 9 meses
Puntos: 9
PHP y PHP4 consulta

Tengo una galeria hecha en php (a secas) y tengo un servidor con PHP4 y no me funciona...que debo hacer para que funque el asunto??? Grax
__________________
Buena Vida...
Francisco

Última edición por Bluesman74cl; 05/02/2004 a las 11:58
  #2 (permalink)  
Antiguo 05/02/2004, 13:15
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
PHP "a secas" ... PHP4?

Cuando uno programa en PHP .. cada función está disponible desde alguna versión de PHP .. sea cual sea .. EL mayor porcentaje de funciones de PHP está disponible desde el principio .. pero algunas en concreto Se crearon en tal versión especifica.

TU debes saber que versión de PHP usa el servidor que dices que tu aplicación funciona. Y si no lo sabes .. lo puedes saber ahora con:

<?
phpinfo();
?>

EL hecho de que "algo" no funcione no sólo depende de si tal función que usas existen a partir de la versión que estás usando .. Sino de la CONFIGURACIÓN de PHP. PHP es muyyyyyyyyyyyyyy sensible a la configuración. Es importantisimo conocer que detalles de configuración puedan afectar a lás funciones o técnicas que estés usando .. y todo eso lo detalla el manual oficial de PHP en cada capítulo de cada grupo de funciones que uses o pertenezca la que busques.

Pero .. ya que preguntas en un foroo .. que MENOS que dar alguna información más sobre tu problema .. lease: CODIGO y error concreto que obtienes para ver que diferencia de configuración pueda existir entre ambos servidores ..la cual (la configuración) la puedes ver haciendo ese phpinfo() a ambos servidores.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 05/02/2004, 13:41
 
Fecha de Ingreso: marzo-2003
Ubicación: onde toy?
Mensajes: 1.437
Antigüedad: 14 años, 9 meses
Puntos: 9
Haber, Cluster lo que pasa es que se ha probado en dos servidores distintos, en uno funciona porque seguro tiene una versión más "añeja" de PHP , por decirlo de alguna forma y por otra ... en el otro servidor no funciona porque tiene PHP4 la verdad es que es una consulta de un amigo asi es que voy a recavar más info...
__________________
Buena Vida...
Francisco
  #4 (permalink)  
Antiguo 05/02/2004, 13:51
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pero hombre .. empieza a hablar con propiedad .. No digas cosas cmo "más añeja" .. Ya te dije que función debes usar para obtener toda la información de PHP .. así que ejecutala (si aun puedes) y toma nota. No hace fata que consultes a tu "amigo" .. lo puedes hacer tu mismo ahora mismo.

Por cierto ... en PHP las versiones son tan importantes como su configuración .. una versión "PHP4" no dice nada .. las versiones son PHP x.y.z (y hasta con RCnº "release candidate nºtal"). Una ligera variación de "z" puede implicar que tal función no se comporte igual que en una versión anterior ...

Y como te comentaba .. SI nos pones los errores que obtienes el código que los genera .. mejor se te podrá ayudar.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #5 (permalink)  
Antiguo 05/02/2004, 17:31
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Un script PHP3 puede funcionar correctamente en un PHP4.3 si este ultimo esta configurado para soportarlo.

Un script que funciona en un PHP4.3 puede no funcionar en otro PHP4.3 si las configuraciones son distintas.

Un script que requiera una extension solo funciona en servidores PHP que tengan instalada esa extension.

Un script que funciona perfectamente en linux puede perfectamente dejar de funcionar en windows.

Uno de los puntos fuertes de PHP es su alto grado de configuracion. Y uno de los inconvenientes de PHP es que te puedes encontrar con multitud de configuraciones.

Los scripts normalmente ponen en la documentacion los requisitos del sistema: version, valores de directivas, etc.

T no puedo decirte nada mas, mi bola de cristal esta en el taller.

Suerte.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:12.