Foros del Web » Programando para Internet » PHP »

PHP sobre Solaris 10

Estas en el tema de PHP sobre Solaris 10 en el foro de PHP en Foros del Web. Hola, Tengo un problema, estoy tratando de hacer una aplicación SAMP (Solaris Apache MySQL PHP) pero tal parece que el php que viene pòr defecto ...
  #1 (permalink)  
Antiguo 14/10/2005, 10:17
 
Fecha de Ingreso: octubre-2005
Mensajes: 3
Antigüedad: 12 años, 2 meses
Puntos: 0
Exclamación PHP sobre Solaris 10

Hola,
Tengo un problema, estoy tratando de hacer una aplicación SAMP (Solaris Apache MySQL PHP) pero tal parece que el php que viene pòr defecto instalado con SOlaris no me está funcionando, supongo que necesito ejecutar alguna configuración adicional, alguien me prodía ayudar por favor?
  #2 (permalink)  
Antiguo 14/10/2005, 10:34
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Has revisado la documentación oficial de PHP sobre su instalación?

http://www.php.net/manual/en/install.unix.sun.php
http://www.php.net/manual/en/install.unix.solaris.php

No conozco "Solaris" .. no sé si dispone de algún sistema de paquetes como RPM's (de Red Had Linux) .. o equivalente .. pero podrías buscar por ahí. Según leo en la documentación de PHP .. dice que dispone de un sistema de paquetes "pkgadd" .. Si tienes más dudas .. intenta consultar en el foro de "Sistemas Operativos" ...

Un saludo,
  #3 (permalink)  
Antiguo 14/10/2005, 11:02
 
Fecha de Ingreso: octubre-2005
Mensajes: 3
Antigüedad: 12 años, 2 meses
Puntos: 0
las he usado.

Ya he buscado en documentación de php, el archivo referente a solaris solo te presenta los pre requisitos, y para usar pkgadd necesitas una rchivo de extensión pkg, y php no lo he visto con esa extensión... insisto en que debe ser algún problema en la configuración del php pues ya está instalado por defecto en SOlaris
  #4 (permalink)  
Antiguo 14/10/2005, 12:17
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
El tema de los "pkg" no los vas a encontrar en PHP.net .. PHP.net sólo proporciona los fuentes de PHP (para que tu los compiles en tu distribución de UNIX/Linux que uses) o el compilado para Windows (ejecutable/instalador). En tal caso en algún repositorio oficial de Solaris o página web oficial de Solaris los podrías encontrar.

Si dices que ya tienes instalado PHP "por defecto" .. tendrás que revisar la configuración de tu servidor HTTP (Apache) si es que está vinculado con PHP ya sea como para ejecutar PHP como "módulo" o como "CGI".

La configuración de Apache para PHP .. la tienes en la misma documentación de PHP.net:
http://www.php.net/manual/en/install.unix.apache2.php
(no sé si usas Apache 1.x o 2.x ? .. revisalo por qué están las indicaciones para una y otra versión).

Cuando hablas de "PHP no me está funcionado" deberías ser algo más concreto con tus pruebas .. No sabemos si tu servidor HTTP en general funciona con una página HTML común .. ni el "efecto" que observas cuando intentas ejecutar un script PHP bajo tu servidor HTTP por una llamada por el URL en un navegador.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:36.