Foros del Web » Programando para Internet » PHP »

php_gd2.dll para hacer thumbnail

Estas en el tema de php_gd2.dll para hacer thumbnail en el foro de PHP en Foros del Web. Hola a todos, Tengo instalado en mi win2000 un easyPhp. Y no me funciona bien la librería php_gd2.dll que tengo en mi directorio /extensions/. He ...
  #1 (permalink)  
Antiguo 22/08/2006, 13:42
 
Fecha de Ingreso: febrero-2004
Mensajes: 157
Antigüedad: 13 años, 10 meses
Puntos: 0
php_gd2.dll para hacer thumbnail

Hola a todos,

Tengo instalado en mi win2000 un easyPhp. Y no me funciona bien la librería php_gd2.dll que tengo en mi directorio /extensions/.

He leido muchas cosas por la web y he cumplimentado lo que me indican en mi php.ini ; a saber:
Código PHP:
Los usuarios de Windows han de instalar el archivo php_gd.dll y 
activar el m
ódulo de la biblioteca en el archivo de configuración php.ini 
(localizado por regla general en el directorio C:Windows). Para activar 
el m
ódulo nada más sencillo que seguir los pasos siguientes:

1.-Abrir con un editor de texto el archivo php.ini.

2.-Localizar en el código del archivo la línea: ;extension=php_gd.dll

3.-Borrar el punto y coma que juega el papel de comentario

4.
-Localizar la sección Paths and Directories y en 
la línea extension_dir= introducir el camino físico en el que 
hemos albergado el archivo php_gd.dll
Ejextension_dir=C:Archivos de programaPHP 
Para instalar la dll en windows, en la línea de comandos he puesto esto:regsvr32 php_gd2.dll

Pero me da error y dice : loadlibrary(php_gd2.dll") failed - No se puede encontrar el módulo esperado
.

También la copié a mi directorio winnt/system32 y lo intenté allí y nada de nada, el mismo error.

¿tengo bien instalada php_gd2.dll?
¿tengo que instalarla en mi win2000? o con la instalación de EasyPhp y los cambios en mi php.ini va que chuta... y el problema lo tengo en el código fuente de mi aplicativo.

Por favor ayudadme... muchas gracias por todo.

Última edición por f_murciano; 22/08/2006 a las 13:58
  #2 (permalink)  
Antiguo 22/08/2006, 13:59
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
¿tengo bien instalada php_gd2.dll?
¿tengo que instalarla en mi win2000? o con la instalación de EasyPhp y los cambios en mi php.ini va que chuta... y el problema lo tengo en el código fuente de mi aplicativo.
Realizas los cambios en tu php.ini como se te indica. Te aseguras de tener en la ruta indicada extension_dir = .. que indicará algo como extensions/ ... y es donde tienes esas php_xxx.dll que son las extensiones de PHP que este tu extensión que quieres habilitar .. reinicias tu servidor y compruebas como te quedó instalada haciendo un:

Código PHP:
<?
phpinfo
();
?>

Cita:
Para instalar la dll en windows, en la línea de comandos he puesto esto:regsvr32 php_gd2.dll
Eso no se debe hacer .. (de donde lo sacastes? .. olvidate de todo lo que estarías acostumbrado a hacer con otros lenguajes o sistemas).

Las extensiones de PHP las maneja PHP directamente .. sólo si alguna extensión concreta requiere de alguna librería más se trataría de mover a tu directorio de sistema alguna otra .dll .. No es el caso para GD.

Olvidate que instalastes PHP y tu servidor HTTP (Apache) con tal o cual instalador: EasyPHP . .ahora centrate en que cada cosa de lo que ese "instalador" te dejó funcionando tiene su configuración y que debes -verla- y tal vez modificarla para casos concretos como el que te atiende.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 22/08/2006, 16:13
 
Fecha de Ingreso: febrero-2004
Mensajes: 157
Antigüedad: 13 años, 10 meses
Puntos: 0
Cracias por responder Cluster,

Sé lo que me pasaba, sólo modifiqué el archivo php.ini de la carpeta php, me fataba modificar el php.ini de la carpeta /conf_files/.

Muchas gracias.

Un saludo
  #4 (permalink)  
Antiguo 22/08/2006, 16:39
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
Iniciado por f_murciano Ver Mensaje
Cracias por responder Cluster,

Sé lo que me pasaba, sólo modifiqué el archivo php.ini de la carpeta php, me fataba modificar el php.ini de la carpeta /conf_files/.

Muchas gracias.

Un saludo
Para que sirva de ejemplo ... El "Php.ini" que manda es el que se indica al hacer un phpinfo() en el primer bloque de información.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:37.