Foros del Web » Programando para Internet » PHP »

Phpldapadmin

Estas en el tema de Phpldapadmin en el foro de PHP en Foros del Web. Hola, alguien me podria ayudar con la configuración del phpldapadmin. Esque tengo un problema, cuando voy a entrar en la herramienta del phpldapadmin me da ...
  #1 (permalink)  
Antiguo 25/08/2004, 03:36
 
Fecha de Ingreso: diciembre-2002
Mensajes: 130
Antigüedad: 15 años
Puntos: 0
Phpldapadmin

Hola, alguien me podria ayudar con la configuración del phpldapadmin.

Esque tengo un problema, cuando voy a entrar en la herramienta del phpldapadmin me da el siguiente error:

http://localhost/phpldapadmin-0.9.4b/

En el marco de la izquierda donde pone My LDAP Server me aparece justo abajo un comentario "no se ha podido conectar al servidor LDAP" pero esta arrancado y cuando le pongo Ldapadd -x -D "cn=Manager,dc=chari,dc=com" -w secret -f base.ldif me pone Adding new entry "dc=chari,dc=com".

Y esta arrancado.
Esta es la parte del config.php que he configurado y está dentro del directorio srv/www/htdocs/phpldapadmin para ver si le veis algun error o algo ok.

Código PHP:
<?php

$i
=0;
$servers = array();
$servers[$i]['name'] = 'My LDAP Server';    
$servers[$i]['host'] = 'localhost'
$servers[$i]['base'] = 'dc=chari,dc=com'
$servers[$i]['port'] = 389;                 
$servers[$i]['auth_type'] = 'config';       
$servers[$i]['login_dn'] = 'cn=Manager,dc=chari,dc=com';
                                            
$servers[$i]['login_pass'] = '';                               
$servers[$i]['tls'] = false;                
$servers[$i]['low_bandwidth'] = false;
$servers[$i]['default_hash'] = 'crypt';
$servers[$i]['login_attr'] = 'dn';          
$servers[$i]['login_class'] = '';
$servers[$i]['read_only'] = false;
$servers[$i]['show_create'] = true;         
$servers[$i]['enable_auto_uid_numbers'] = true;  
$servers[$i]['auto_uid_number_mechanism'] = 'search'
$servers[$i]['auto_uid_number_search_base'] = 'ou=People,dc=chari,dc=com'
$servers[$i]['auto_uid_number_min'] = 1000;
$servers[$i]['auto_uid_number_uid_pool_dn'] = 'cn=uidPool,dc=chari,dc=com'
$servers[$i]['auto_uid_number_search_dn'] = '';
$servers[$i]['auto_uid_number_search_dn_pass'] = '';
Muchas gracias. Saludos.
  #2 (permalink)  
Antiguo 25/08/2004, 06:24
 
Fecha de Ingreso: diciembre-2002
Mensajes: 130
Antigüedad: 15 años
Puntos: 0
Ya he resuelto el problema anterior la solucion era:

$servers[$i]['login_pass'] = 'contraseña';

Ahora tengo otro problema:

Cuando entro en la herramienta phpldapadmin y pincho en crear. Me sale la ventana diciendome lo siguiente:

New user account
Hint to customize this template, edit the file templates/creation/new_user_template.php

Error
Your phpldapadmin configuration specifies an invalid auto_uid_search_base for server My LDAP Server.

En el config.php tengo puesto:

$servers[$i]['auto_uid_number_search_base']= 'ou=People,dc=chari,dc=com';

/* The DN of the search base when the 'search'
mechanism is used above. */
  #3 (permalink)  
Antiguo 26/08/2004, 02:46
 
Fecha de Ingreso: diciembre-2002
Mensajes: 130
Antigüedad: 15 años
Puntos: 0
Nadie puede ayudarme con el tema

Esque estoy un poco desesperada.
Muchas gracias.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:31.