Foros del Web » Programando para Internet » PHP »

Por que no me muestra la foto???????

Estas en el tema de Por que no me muestra la foto??????? en el foro de PHP en Foros del Web. Hola, tengo un script que me lee una tabla y allí carga un nombre de una foto a la que luego quiero ver y ne ...
  #1 (permalink)  
Antiguo 24/11/2004, 16:06
 
Fecha de Ingreso: noviembre-2003
Mensajes: 362
Antigüedad: 14 años
Puntos: 7
Por que no me muestra la foto???????

Hola, tengo un script que me lee una tabla y allí carga un nombre de una foto a la que luego quiero ver y ne me la muestra alguien sabe por que ????.

En la linea que esta en magenta levanto el nombre de la foto y la paso a

echo " <td align='LEFT' bgcolor='#FFFFFF'><font face='Verdana' size='1' color='#000000'>".$Tipo_op."</font></td>";
echo " <td><a href='muestrafoto.php?Nfoto=$Nfoto'>Ver +--></a></td>"; echo "</tr>";
$row++;
}
mysql_free_result($result);
mysql_close();

En la linea que esta en magenta (arriba) levanto el nombre de la foto y la paso a el sript que está abajo, este es el que no me muestra nada, alguien me ayuda ???? GRACIAS

<html>
<body>
<p><img border="0" src="file:///C:/Inetpub/wwwroot/imag/<? $Nfoto ?>" width="100" height="102"></p>

</body>
</html>
  #2 (permalink)  
Antiguo 24/11/2004, 16:18
Avatar de nicolaspar  
Fecha de Ingreso: noviembre-2004
Ubicación: Villa Ballester Bs-As|Ar
Mensajes: 2.002
Antigüedad: 13 años
Puntos: 34
<html>
<body>
<p><img border="0" src="file:///C:/Inetpub/wwwroot/imag/<?php echo $_GET["Nfoto"];?>" width="100" height="102"></p>

</body>
</html>
  #3 (permalink)  
Antiguo 24/11/2004, 16:21
Avatar de Willjce  
Fecha de Ingreso: diciembre-2003
Ubicación: Lima - Peru
Mensajes: 67
Antigüedad: 14 años
Puntos: 0
Sonrisa

Hola Parliament .:::::.

bueno tu codigo de colocar la imagen es
Código HTML:
<p><img border="0" src="file:///C:/Inetpub/wwwroot/imag/<? $Nfoto ?>" width="100" height="102"></p> 
te explico, estaria mal llamar a un archivo con ese parametro q pones.
Te explico detalladamente :
Si tu carpeta raiz donde estan todas tus paginas web es : C:/Inetpub/wwwroot/*.* --> ok
y tus fotos se ubican en : C:/Inetpub/wwwroot/imag/*.img --> ok

en el codigo sera asi :
Código HTML:
<p><img border="0" src="imag/<?=$Nfoto?>" width="100" height="102"></p> 
nada mas... bueno ponlo en prueba y me cuentas o chau saludos....
__________________
Cita:
El éxito se alcanza convirtiendo cada paso en una meta y cada meta en un paso :pensando:
Att...
Tu amigo Willy... :aplauso:

Última edición por Willjce; 24/11/2004 a las 17:57
  #4 (permalink)  
Antiguo 24/11/2004, 16:26
Avatar de nicolaspar  
Fecha de Ingreso: noviembre-2004
Ubicación: Villa Ballester Bs-As|Ar
Mensajes: 2.002
Antigüedad: 13 años
Puntos: 34
El tema es que esta haciendo <? $Nfoto ?>, y deveria hacer un echo de eso, ademas de levantarlo, como en mi ejemplo.
<?php echo $_GET["Nfoto"];?>
  #5 (permalink)  
Antiguo 24/11/2004, 20:35
 
Fecha de Ingreso: noviembre-2003
Mensajes: 362
Antigüedad: 14 años
Puntos: 7
Muy bueno lo tuyo nicolaspar

Gracias a todos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:11.