Foros del Web » Programando para Internet » PHP »

Porque no funciona!

Estas en el tema de Porque no funciona! en el foro de PHP en Foros del Web. Hola.. tengo lo siguiente cuando ingreso a una url Código PHP: <? function  encabezado (){          Header ( "WWW-Authenticate: Basic realm=\"Central de clientes -Avansoft S.A\"" );          Header ( "HTTP/1.0 401 Unauthorized" ); ...
  #1 (permalink)  
Antiguo 05/06/2006, 13:01
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
Porque no funciona!

Hola.. tengo lo siguiente cuando ingreso a una url

Código PHP:
<?
function encabezado(){
        
Header("WWW-Authenticate: Basic realm=\"Central de clientes -Avansoft S.A\"");
        
Header("HTTP/1.0 401 Unauthorized");
}

if(!isset(
$PHP_AUTH_USER)) {
    
encabezado();
}else{
    include(
'autentificador/aut_seguridad.php');
    if ( 
$valido != "S" ){
        
encabezado();
    }
}
?>
y el include es éste

Código PHP:
require_once('../config/conecta.php');
$conectar Conectarse();
$codigo $PHP_AUTH_USER;
$pass $PHP_AUTH_PW;
$password =  md5($pass);
$valido "S";
$RESULT=mysql_query("SELECT * FROM TCCL_USUARIOS WHERE CDUSUARIO = '$codigo'",$conectar);
while (
$ROW mysql_fetch_array($RESULT))
{
    if (
$password != $ROW['DSPASSWORD'])
    {
        
$valido "N";
    }

y bueno no pasa nada.. :( la idea es que al recibir el usuario y el password yo pueda comparar ambos con lo que tengo en la base de datos.. pero nada.. no quiere funcionar.. pero si hago esto ahi si funciona.. ya no sé que hacerle o a que se deba el que no funcione:

Código PHP:
<?
function encabezado(){
        
Header("WWW-Authenticate: Basic realm=\"Central de clientes -Avansoft S.A\"");
        
Header("HTTP/1.0 401 Unauthorized");
}

if(!isset(
$PHP_AUTH_USER)) {
    
encabezado();
}else{
    if ( 
$PHP_AUTH_PW != "1234" ){ // considerando que se digita 1234 como login
        
encabezado();
    }
}
?>

  #2 (permalink)  
Antiguo 05/06/2006, 13:13
Avatar de mauled  
Fecha de Ingreso: marzo-2005
Ubicación: Cd. de México.
Mensajes: 3.001
Antigüedad: 12 años, 9 meses
Puntos: 33
De acuerdo

Echale un ojo a este link http://www.webestilo.com/php/php11a.phtml. Lee la parte en donde dice atención.
Saludillos.
  #3 (permalink)  
Antiguo 05/06/2006, 13:24
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
ah pero es que el código me sirve.. el lio ha estado cuándo intento hacer las consultas a las bases de datos.. o incluyo otros archivos.. :(
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:17.