Foros del Web » Programando para Internet » PHP »

Posible ataque?

Estas en el tema de Posible ataque? en el foro de PHP en Foros del Web. Tengo dudas de que 2 de mis web estén sufriendo ataques. En ambas, a veces, en vez de abrir la página me descarga en archivo ...
  #1 (permalink)  
Antiguo 02/05/2006, 04:30
Avatar de ldp
ldp
 
Fecha de Ingreso: marzo-2005
Ubicación: Por fin, en mi nueva casa!
Mensajes: 617
Antigüedad: 12 años, 9 meses
Puntos: 3
Pregunta Posible ataque?

Tengo dudas de que 2 de mis web estén sufriendo ataques.

En ambas, a veces, en vez de abrir la página me descarga en archivo .php. Ejemplo, si quiero ir al inicio me descarga el archivo news.php.

En una de mis web hecha en xoops, esto sólo ocurre con algunos archivos y no es grave. En la otra web hecha en e107 ocurre en todos los archivos y no se abre la web pq se abre la ventana de descarga del archivo.

Puede ser que estén recibiendo ataques? Cuál sería la solución? GRacias x cualquier info que me podáis dar.

P.D.: No sé exactamente dónde puede ir esta pregunta, pero como mi web es php la pongo aquí.
  #2 (permalink)  
Antiguo 02/05/2006, 04:39
Avatar de Nefertiter  
Fecha de Ingreso: enero-2003
Ubicación: Rosario
Mensajes: 1.316
Antigüedad: 14 años, 11 meses
Puntos: 8
eso me suena muy raro :S, lo unico q se me ocurre es lo mas tonto... estas ejecutando los archivos a traves de un servidor con soporte para php? :S
  #3 (permalink)  
Antiguo 02/05/2006, 04:52
Avatar de ldp
ldp
 
Fecha de Ingreso: marzo-2005
Ubicación: Por fin, en mi nueva casa!
Mensajes: 617
Antigüedad: 12 años, 9 meses
Puntos: 3
Sí, si la cosa iba bien hasta hace un momento. Creo que es problema de la base de datos. pero no sé cómo arreglarlo. He cambiado el nombre y la pass del usuario de la base de datos por si alguien estaba ejecutando un ataca o había conseguido los datos o algo. Y cambie el config con los nuevos datos, pero sigue igual...

Puede tener algo que ver las librería GD?? Ya me han dado problemas antes con otras cosas.
  #4 (permalink)  
Antiguo 02/05/2006, 08:12
Avatar de ldp
ldp
 
Fecha de Ingreso: marzo-2005
Ubicación: Por fin, en mi nueva casa!
Mensajes: 617
Antigüedad: 12 años, 9 meses
Puntos: 3
Ya resolví el problema. Bueno, no lo resolví, pero lo individué. Es debido a las librerías gd. Desactivé un módulo y se resolvió, ahora me queda saber cómo hago para solucionarlo del todo. Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:15.