Foros del Web » Programando para Internet » PHP »

Posible problema con php.ini

Estas en el tema de Posible problema con php.ini en el foro de PHP en Foros del Web. Hola Mucho tiempo que no venia por aca, un saludo a todos. Les comento mi problema. Utilice la función strcmp(A,B), donde A="algo" y B="algo" esos ...
  #1 (permalink)  
Antiguo 24/01/2018, 12:27
Avatar de a n g e l u s  
Fecha de Ingreso: enero-2006
Ubicación: Chile
Mensajes: 237
Antigüedad: 12 años, 4 meses
Puntos: 1
Pregunta Posible problema con php.ini

Hola

Mucho tiempo que no venia por aca, un saludo a todos.

Les comento mi problema.

Utilice la función strcmp(A,B), donde A="algo" y B="algo" esos algo son iguales por lo que el retorno debiera ser 0.

La cosa es que me devuelve el valor en positivo o negativo, pero no los identifica como igual. Debido a esto comence a usar cada una de las funciones de string y ninguna me funciona en forma correcta.

Mi solicitud de ayuda es: Donde reviso las librerias de apache, como verifico si las rutas estan correctas. Si alguien tiene alguna alternativa, que no sea la mas evidente de desintalar e instalar nuevamente, bienvenida sea.

De antemano Gracias.
__________________
Atte,
A n g e l u s
Concepción - Chile
más vale respuestas bien pensadas, que 7000 post
  #2 (permalink)  
Antiguo 24/01/2018, 12:29
 
Fecha de Ingreso: octubre-2009
Mensajes: 285
Antigüedad: 8 años, 7 meses
Puntos: 25
Respuesta: Posible problema con php.ini

puede ser un tema de codificación, la función es segura a nivel binario, revisa la codificación de cada origen de datos
  #3 (permalink)  
Antiguo 24/01/2018, 12:36
Avatar de a n g e l u s  
Fecha de Ingreso: enero-2006
Ubicación: Chile
Mensajes: 237
Antigüedad: 12 años, 4 meses
Puntos: 1
Respuesta: Posible problema con php.ini

Hola sustentio,

chequeado, esta el archivo codificado con UTF-8, y vuelto hacer por si acaso. Pero no es la solución al problema.

Gracias por tu respuesta
__________________
Atte,
A n g e l u s
Concepción - Chile
más vale respuestas bien pensadas, que 7000 post
  #4 (permalink)  
Antiguo 25/01/2018, 10:57
Avatar de Triby
Mod on free time
 
Fecha de Ingreso: agosto-2008
Ubicación: $MX->Gto['León'];
Mensajes: 9.839
Antigüedad: 9 años, 9 meses
Puntos: 2141
Respuesta: Posible problema con php.ini

Puedes poner un código de ejemplo para tratar de replicar el error?
__________________
- León, Guanajuato
- GV-Foto



La zona horaria es GMT -6. Ahora son las 01:39.