Foros del Web » Programación web » PHP »

POSTGRESQL Error: Call to undefined function pg_connect()

Estas en el tema de POSTGRESQL Error: Call to undefined function pg_connect() en el foro de PHP en Foros del Web. Buenas Tardes, Tengo instalado en mi maquina Apache 2.0, PHP 5 y PostgreSql 8.1 Al parecer Apache y PHP corren perfetamente hasta que intento conectarme ...
  #1 (permalink)  
Antiguo 16/05/2006, 15:45
 
Fecha de Ingreso: marzo-2004
Mensajes: 27
Antigüedad: 10 años, 7 meses
Puntos: 0
Exclamación POSTGRESQL Error: Call to undefined function pg_connect()

Buenas Tardes,

Tengo instalado en mi maquina Apache 2.0, PHP 5 y PostgreSql 8.1 Al parecer Apache y PHP corren perfetamente hasta que intento conectarme con una base de datos en PostgreSql.

Uso el siguiente string de conexion:

Código PHP:
// Conexion, seleccion de base de datos
$conexion_bd pg_connect("host=localhost dbname=bdprueba user=postgres password=xxx"
Y me da el siguiente error: Call to undefined function pg_connect()

Pues, ya anadi en el php.ini la carpeta de las extensiones

Código:
; Directory in which the loadable extensions (modules) reside.
extension_dir = "C:\php\ext"
Y habilite la extension de postgre

Código:
;extension=php_oracle.dll

extension=php_pgsql.dll

;extension=php_shmop.dll
Ademas de eso, reinicie la maquina completa.. Y no funciona...

En el path ya tengo anadido "c:\php"

He buscado informacion por todos lados y esto es lo unico que consigo..
Alguna idea? Espero haber sido explicita Jajaja

Muchas gracias de anticipado por su ayuda..

Elsy
  #2 (permalink)  
Antiguo 16/05/2006, 16:51
Avatar de mauled  
Fecha de Ingreso: marzo-2005
Ubicación: Cd. de México.
Mensajes: 3.002
Antigüedad: 9 años, 8 meses
Puntos: 33
De acuerdo

Verifica este link http://www.forosdelweb.com/showthrea...ght=POSTGRESQL ,y echale un ojo el comentario que hace Cluster.


Saludillos.
  #3 (permalink)  
Antiguo 17/05/2006, 08:29
 
Fecha de Ingreso: marzo-2004
Mensajes: 27
Antigüedad: 10 años, 7 meses
Puntos: 0
Holas!

Gracias por la ayuda.. Ya habia leido esas soluciones y ninguna funcionaba..

Lo que paso fue que en el momento de cambiar el archivo php.ini-recommended use un archivo equivocado (ini dist o algo asi) y php no tenia archivo ini!

Me di cuenta, modifique el .ini (ahora php si tiene) y ya no se carga con configuraciones por defecto y yo puedo modificar las opciones..

:)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Tema Cerrado




La zona horaria es GMT -6. Ahora son las 22:36.
SEO by vBSEO 3.3.2