Foros del Web » Programando para Internet » PHP »

La primera en la frente

Estas en el tema de La primera en la frente en el foro de PHP en Foros del Web. Hola, Estoy intentando hacer mi primer script en PHP, pero tras consultar un manual e intentar ejecutar el más básico de los códigos me encuentro ...
  #1 (permalink)  
Antiguo 21/05/2010, 02:02
 
Fecha de Ingreso: septiembre-2004
Ubicación: Andorra
Mensajes: 130
Antigüedad: 15 años, 1 mes
Puntos: 0
La primera en la frente

Hola,

Estoy intentando hacer mi primer script en PHP, pero tras consultar un manual e intentar ejecutar el más básico de los códigos me encuentro que no funciona como debe. Sale el título en el navegador pero no el mensaje "Hola mundo".
¿ Qué debo hacer para que funcione ?

Código:
<html>
  <head>
    <!-- bloque de etiquetas META  -->
    <title>Titulo de la web</title>
  </head>
  <body>     
<?php
      echo "Hola Mundo";	  
?>      
</html>
  #2 (permalink)  
Antiguo 21/05/2010, 02:09
 
Fecha de Ingreso: marzo-2008
Mensajes: 57
Antigüedad: 11 años, 7 meses
Puntos: 0
Respuesta: La primera en la frente

hola,

Tienes que cerrar el tag de body y te ira :)

algo tal q asi

Código PHP:
Ver original
  1. <html>
  2.   <head>
  3.     <!-- bloque de etiquetas META  -->
  4.     <title>Titulo de la web</title>
  5.   </head>
  6.   <body>
  7.     </body>
  8. <?php
  9.       echo "Hola Mundo";     
  10. ?>      
  11. </html>

Que vaya bien
  #3 (permalink)  
Antiguo 21/05/2010, 02:14
fiu
 
Fecha de Ingreso: diciembre-2006
Ubicación: Barcelona
Mensajes: 128
Antigüedad: 12 años, 9 meses
Puntos: 8
Respuesta: La primera en la frente

no has cerrado el body despues del php, pero aún así creo que deberia verse.
Esta bien instalado el php? prueba una página absolutamente vacia con este codigo:
Código PHP:
Ver original
  1. <?php phpinfo(); ?>
y asegurate de que el archivo tenga extension php, no se que windows te está ocultando la extension.
  #4 (permalink)  
Antiguo 21/05/2010, 02:21
 
Fecha de Ingreso: septiembre-2004
Ubicación: Andorra
Mensajes: 130
Antigüedad: 15 años, 1 mes
Puntos: 0
Respuesta: La primera en la frente

Hola,

Gracias a ambos, las dos soluciones han funcionado, el problema era que el archivo estaba grabado con extensión htm en vez de php.
Gracias

Etiquetas: primera
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:42.