Foros del Web » Programando para Internet » PHP »

Problema al abrir directorio de imágenes

Estas en el tema de Problema al abrir directorio de imágenes en el foro de PHP en Foros del Web. Hola Mi estructura de archivos es la siguiente: - index.php - carpeta imágenes y dentro una subcarpeta llamada baners dónde tengo guardado varias imágenes. En ...
  #1 (permalink)  
Antiguo 10/11/2010, 10:32
 
Fecha de Ingreso: marzo-2008
Mensajes: 186
Antigüedad: 11 años, 8 meses
Puntos: 3
Problema al abrir directorio de imágenes

Hola

Mi estructura de archivos es la siguiente:

- index.php
- carpeta imágenes y dentro una subcarpeta llamada baners dónde tengo guardado varias imágenes.

En indez.php dónde quiero que salgan las imágenes tengo el siguiente código escrito:

Código PHP:
Ver original
  1. <?php
  2.     $carpeta = "imagenes";
  3.     $subcarpeta = "baner";
  4.     $dir = opendir($carpeta."/".$subcarpeta."/");
  5.     while($leer = readdir($dir)){
  6.         echo "<img src='$carpeta/$subcarpeta/$leer' height='248' width='890' alt='imagen_banner' />";
  7.     }
  8.     closedir($dir);
  9. ?>

Las imágenes se muestran sin problemas, lo único que antes de la primera imagen se muestra un espacio en blanco que corresponde a la ruta imágenes/baner...

¿Cómo puedo modificar el código para que se reproduzcan sólo las imágenes y se salte ese espacio que corresponde a la ruta de los archivos?

Gracias por anticipado, espero vuestras respuestas
  #2 (permalink)  
Antiguo 10/11/2010, 11:17
Avatar de Nano_  
Fecha de Ingreso: febrero-2006
Ubicación: Bogotá, Colombia
Mensajes: 1.866
Antigüedad: 13 años, 9 meses
Puntos: 96
Respuesta: Problema al abrir directorio de imágenes

Saludos

Podrias probar de la siguiente manera

Código PHP:
<?php
    $carpeta 
"imagenes";
    
$subcarpeta "baner";

if (
$dir opendir($carpeta."/".$subcarpeta."/")) {
echo 
$dir;
 while (
false !== ($leer readdir($dir))) {
          echo 
"<img src='$carpeta/$subcarpeta/$leer' height='248' width='890' alt='imagen_banner' />";
    }
    
closedir($dir);
}
?>
__________________
:.:Nano.:: @nano_hard - Retornando al foro
  #3 (permalink)  
Antiguo 10/11/2010, 11:23
 
Fecha de Ingreso: marzo-2008
Mensajes: 186
Antigüedad: 11 años, 8 meses
Puntos: 3
Respuesta: Problema al abrir directorio de imágenes

Nano, gracias por tu ayuda, pero el problema sigue. Me muestra primero un fondo blanco que corresponde a la ruta de dichos archivos y a continuación las imágenes

Etiquetas: directorio
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 15:29.