Foros del Web » Programando para Internet » PHP »

Problema acentos webService

Estas en el tema de Problema acentos webService en el foro de PHP en Foros del Web. Hola a todos! Tengo un webService para una app de android en PHP que me va estupendamente, hasta que hay que insertar un acento en ...
  #1 (permalink)  
Antiguo 07/01/2015, 04:08
 
Fecha de Ingreso: febrero-2013
Mensajes: 25
Antigüedad: 6 años, 10 meses
Puntos: 2
Problema acentos webService

Hola a todos!

Tengo un webService para una app de android en PHP que me va estupendamente, hasta que hay que insertar un acento en la base de datos, que inserta hasta el acento.

Tengo el cotejamiento de las Tablas en UTF8_unicode y el de los varchar de los campos de las tablas en UTF-8_spanish_ci.

He probado a codificar desde android en UTF8 pero entonces no me reconoce bien el valor de las variables, por tanto creo que la solución es codificar desde php.

No sé si hay alguna manera de codificar y decodificar todo mas o menos automaticamente o tengo que ir campo por campo.

Muchas gracias por vuestro tiempo y ayuda!
  #2 (permalink)  
Antiguo 07/01/2015, 10:57
Avatar de hhs
hhs
Colaborador
 
Fecha de Ingreso: junio-2013
Ubicación: México
Mensajes: 2.995
Antigüedad: 6 años, 5 meses
Puntos: 379
Respuesta: Problema acentos webService

revisa el manual: http://php.net/manual/en/function.utf8-decode.php para hacer la decodificación puedes recorrer el input que recives de android o usar php filter: http://php.net/manual/es/function.fi...nput-array.php con el uso de FILTER_CALLBACK
__________________
Saludos
About me
Laraveles
A class should have only one reason to change.

Etiquetas: decode, encode, utf-8, webservice
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:15.