Foros del Web » Programando para Internet » PHP »

Problema al Actualizar Php

Estas en el tema de Problema al Actualizar Php en el foro de PHP en Foros del Web. hola buenas mirad he actualizado mi php ha: 4.4.2 y resulta que un script para thumbnails con libreria GD no me funciona!!!!.......el script lo saque ...
  #1 (permalink)  
Antiguo 11/02/2006, 21:46
Avatar de Diabolus  
Fecha de Ingreso: diciembre-2004
Mensajes: 453
Antigüedad: 13 años
Puntos: 0
Problema al Actualizar Php

hola buenas mirad he actualizado mi php ha: 4.4.2 y resulta que un script para thumbnails con libreria GD no me funciona!!!!.......el script lo saque del foro es este:

Código PHP:
<?php
$arc
=$_GET['ruta'];
$image imagecreatefromjpeg($arc); 
$img_w imagesx($image); 
$img_h imagesy($image); 
$new_img_w $_GET['ancho'];
$new_img_h $_GET['alto'];
$new_img_source imagecreatetruecolor($new_img_w,$new_img_h);
imagecopyresampled($new_img_source$image0000$new_img_w$new_img_h,$img_w$img_h);
header("Content-type: image/jpeg"); 
imagejpeg($new_img_source); 
?>

Segun e phpinfo tengo bien instalada la libreria GD :S que puede ser?

gracias ;)

p.D: Me da este error:

Error CGI
La aplicación CGI especificada puede comportarse de forma anormal si no recibe un conjunto completo de encabezados HTTP.
  #2 (permalink)  
Antiguo 12/02/2006, 02:53
Avatar de Diabolus  
Fecha de Ingreso: diciembre-2004
Mensajes: 453
Antigüedad: 13 años
Puntos: 0
nadie?:(.................
  #3 (permalink)  
Antiguo 13/02/2006, 05:48
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Y como instalastes tu actualización de PHP? Instalastes PHP como CGI? (bajo que servidor HTTP lo estás usando?)

El error que describes es bastante genérico .. Me refiero a que se emite ese mensaje de error tal cual para muchos tipos de problemas . .no sólo con uso de GD o esas cabeceras HTTP que envias por header().

Un saludo,
  #4 (permalink)  
Antiguo 14/02/2006, 07:00
 
Fecha de Ingreso: febrero-2006
Mensajes: 1
Antigüedad: 11 años, 9 meses
Puntos: 0
Hola,

yo tambien obtengo el mismo error cuando trato de entrar en la pagina por defecto de phpmyadmin configurado mediante el metodo de autentificacion por cookies.

Obviamente, si uso el metodo config con el usuario y password en el fichero config.inc.php entro sin problemas, pero no quiero permitir ese agujero de seguridad.

El error se produce despues de la pagina que me pide usuario y password.

Tengo instalado PHP c'omo CGI.

Gracias por adelantado.

Saludos.
  #5 (permalink)  
Antiguo 14/02/2006, 07:16
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Podrían revisar esta FAQ:
http://www.forosdelweb.com/showthrea...744#post298744

En modo CGI recuerden que PHP es altamente sensible a los permisos de los scripts/contenido en general que se llame. No sé que S.O. usan .. pero revisen ese tema (den permisos de ejecución a sus scripts .. de lectura/escritura a sus datos .. etc).

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:42.