Foros del Web » Programando para Internet » PHP »

Problema al borrar registro en el servidor. Funciona en local

Estas en el tema de Problema al borrar registro en el servidor. Funciona en local en el foro de PHP en Foros del Web. El problema es que funciona en local con el XAMPP, pero al subirlo al servidor no funciona, no borra el registro. ¿Alguien sabe por donde ...
  #1 (permalink)  
Antiguo 19/05/2015, 14:33
 
Fecha de Ingreso: junio-2009
Mensajes: 30
Antigüedad: 10 años, 6 meses
Puntos: 0
Problema al borrar registro en el servidor. Funciona en local

El problema es que funciona en local con el XAMPP, pero al subirlo al servidor no funciona, no borra el registro. ¿Alguien sabe por donde pueden ir los tiros?, ¿se necesita alguna versión de php específica o algo así?
Saludos y Gracias.
Antonio


Este es el código JavaScript

Código:
<script language="JavaScript">
 
   function confirmar(url){ 
      if (!confirm("¿Está seguro de que desea eliminar el registro?")) { 
         return false; 
      } 
      else { 
         document.location= url; 
         return true; 
      } 
   } 
</script>
....

Luego el enlace para borrar es este:
Código PHP:
<a href="javascript:;" 
            onclick="confirmar('index.php?br=<?php echo $ref3?>')
            ;return false;">Borrar</a><a href="javascript:;" 
            onclick="confirmar('index.php?br=<?php echo $ref3?>')
            ;return false;">Borrar</a>
  #2 (permalink)  
Antiguo 19/05/2015, 14:41
Avatar de gnzsoloyo
Moderador criollo
 
Fecha de Ingreso: noviembre-2007
Ubicación: Actualmente en Buenos Aires (el enemigo ancestral)
Mensajes: 23.321
Antigüedad: 12 años
Puntos: 2653
Respuesta: Problema al borrar registro en el servidor. Funciona en local

Bueno... allí no veo nada de PHP, mas que algunos detalles sueltos que no están vinculados con acciones a realizar con la base de datos... El resto es puro JavaScript.
Asumiré que estás intentando hacer algo con Ajax, porque de lo contrario...
__________________
¿A quién le enseñan sus aciertos?, si yo aprendo de mis errores constantemente...
"El problema es la interfase silla-teclado." (Gillermo Luque)

Última edición por gnzsoloyo; 19/05/2015 a las 22:17

Etiquetas: local, registro, servidor
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:04.