Foros del Web » Programando para Internet » PHP »

Problema con $_GET

Estas en el tema de Problema con $_GET en el foro de PHP en Foros del Web. Hola a todos... actualmente estoy haciendo un proyecto en el cual uso 3 $_GET's Código PHP: $accion = $_GET [ 'accion' ];  //Lo que se realizara (Borrar/Editar/Agregar) $que = ...
  #1 (permalink)  
Antiguo 16/09/2007, 15:16
 
Fecha de Ingreso: marzo-2007
Ubicación: Nayarit,Mexico
Mensajes: 87
Antigüedad: 12 años, 11 meses
Puntos: 1
Pregunta Problema con $_GET

Hola a todos... actualmente estoy haciendo un proyecto en el cual uso 3 $_GET's
Código PHP:
$accion=$_GET['accion']; //Lo que se realizara (Borrar/Editar/Agregar)
$que=$_GET['que']; // Categoria o Subcategoria
$cual=$_GET['cual'];// el id de la categoria que se borrará o editará 
Tengo un switch para verificar que es lo que se va hacer (Borrar/Editar/Agregar)
Código PHP:
switch ($accion){
case 
"agregar"//blablalblabba 
break;
case  
"editar"//blblalblablaba
 
break;
case 
"borrar"//blblablbal 
break;
default: 
//blablablabla 
break;

Todo funciona correctamente , pero solo con Categoria a la hora de poner subcategoria en el $_GET de que , no pasa nada, me regresa al default de mi sistema de modulacion (Otro , el principal )...

Porque pasa esto?... Como lo soluciono ... Gracias a todos por su tiempo en leer esto
  #2 (permalink)  
Antiguo 16/09/2007, 15:37
 
Fecha de Ingreso: abril-2007
Mensajes: 144
Antigüedad: 12 años, 9 meses
Puntos: 4
Re: Problema con $_GET

Seguramente el problema este en el codigo que hace la peticion GET.
Bien sea un formulario, o una url directamente.

Quizas deberias de poner el codigo que hace la llamada a la paguina.
  #3 (permalink)  
Antiguo 16/09/2007, 15:40
 
Fecha de Ingreso: marzo-2007
Ubicación: Nayarit,Mexico
Mensajes: 87
Antigüedad: 12 años, 11 meses
Puntos: 1
Re: Problema con $_GET

es un link..
  #4 (permalink)  
Antiguo 17/09/2007, 17:28
Avatar de Seppo  
Fecha de Ingreso: marzo-2005
Ubicación: Buenos Aires, Argentina
Mensajes: 1.284
Antigüedad: 14 años, 11 meses
Puntos: 17
Re: Problema con $_GET

Estás teniendo en cuenta la diferencia entre mayúsculas y minúsculas?
Cuando levantás el GET estás usando mayúscula para la palabra y después todo en minúscula, según tu código
  #5 (permalink)  
Antiguo 17/09/2007, 22:05
 
Fecha de Ingreso: marzo-2007
Ubicación: Nayarit,Mexico
Mensajes: 87
Antigüedad: 12 años, 11 meses
Puntos: 1
Re: Problema con $_GET

ya lo solucioné gracias... usaba dos $_GET's iguales y no lo ahbia notado
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:34.