Foros del Web » Programando para Internet » PHP »

Problema Con $_get En Autentificator

Estas en el tema de Problema Con $_get En Autentificator en el foro de PHP en Foros del Web. HOLA, TENGO UN PROBLEMA FATAL. ESTOY HACIENDO UN SITIO QUE SE LOGEA CON AUTENTIFICATOR. LA PRIMERA PAGINA (inicio.php) CONTIENE EXACTAMENTE LA MISMA INFORMACION QUE LA ...
  #1 (permalink)  
Antiguo 22/08/2005, 10:09
Avatar de fatherjuan  
Fecha de Ingreso: mayo-2005
Ubicación: Estado de México
Mensajes: 132
Antigüedad: 12 años, 6 meses
Puntos: 0
Problema Con $_get En Autentificator

HOLA, TENGO UN PROBLEMA FATAL.

ESTOY HACIENDO UN SITIO QUE SE LOGEA CON AUTENTIFICATOR.

LA PRIMERA PAGINA (inicio.php) CONTIENE EXACTAMENTE LA MISMA INFORMACION QUE LA PAGINA SEGURA (principal.php)
EN LAS DOS TENGO UN MENU HECHO CON FIRE WORKS QUE PASA EL VALOR DE CADA SUBMENU POR $_GET, DE ESTA FORMA: incio.php?equipo=AMFBMX,. EN LA PRIMERA PAGINA FUNCIONA PERFECTAMENTE, PERO LA SEGUNDA QUE UTILIZA EL aut_verifica.php, ME ENVIA AL ERROR 1, ACCESO INCORRECTO, LO RARRO ES QUE YO PROGRAMO EN MACOSX Y EN MI SISTEMA OPERATIVO EL SITIO FUNCIONA PERFECTAMENTE, PERO EN WINDOWS , POR OTRA PARTE ALGUNOS VALORES LOS PASO POR $_GET EN LA MISMA PAGINA QUE USA aut_verifica.php Y LA PAGINA LOS RECIBE SIN NINGUN PROBLEMA.

!!!!, POR FAVOR AYUDA!!!! CLUSTER O QUIEN SEA

GRACIAS
  #2 (permalink)  
Antiguo 22/08/2005, 11:21
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Indica el código que usas para ver tu proceso.

De todas formas .. el error "cod.1" se origina cuando no se puede obtener la información de "página referida" (HTTP_REFERER). Esto por ejemplo sucede cuando se usa javascript para lanzar link's/ventanas (no sé si será tu caso .. pero parecer que sí).

Si tienes problemas con esa porción de código, .. puedes eliminarlo sin problemas. La seguridad igual se controla por las sesiones y su validación que llega a continuación.

Un saludo,
  #3 (permalink)  
Antiguo 22/08/2005, 12:48
Avatar de fatherjuan  
Fecha de Ingreso: mayo-2005
Ubicación: Estado de México
Mensajes: 132
Antigüedad: 12 años, 6 meses
Puntos: 0
Caray Me Apanique, Pero Con Ese Error No Funciona El Sitiio, Te Agradezco Mil Veces. Le Quite Ese If Y Funciona Bien.
Estoy Muy Contento Con El Modulo.

Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:27.