Foros del Web » Programando para Internet » PHP »

problema con avatares en foro

Estas en el tema de problema con avatares en foro en el foro de PHP en Foros del Web. bueno en el foro ke he programado estoy añadiendole la opcion de mostrar el avatar ke el usuario a seleccionado (la url del avatar se ...
  #1 (permalink)  
Antiguo 05/09/2005, 12:45
Avatar de ZydRick  
Fecha de Ingreso: febrero-2005
Ubicación: Lima
Mensajes: 750
Antigüedad: 12 años, 10 meses
Puntos: 4
problema con avatares en foro

bueno en el foro ke he programado estoy añadiendole la opcion de mostrar el avatar ke el usuario a seleccionado (la url del avatar se guarda en la tabla de los usuarios) y bueno hice la consulta ke muestra el post enviado junto al avatar del usuario de esta manera:

Código PHP:
<?
session_start
();
include(
'config.php');
include(
'bbcode1.php');
$query "select * from foros where id='$id'";
$resp mysql_query($query);
while (
$datos mysql_fetch_array($resp)) {

if (!
session_id()) session_start();
$num $datos["visitas"] + 1;
$foro "foro".$id;
if(!isset(
$_SESSION["foro"]) OR $_SESSION["foro"]<>$foro) {
mysql_query("update foros set visitas='$num' where id='$id'"); // cuento la visita o lectura
}
$_SESSION['foro'] =  "foro".$id;

$fecha date("d/m/Y",$datos[fecha]);
$des $datos[descripcion];
$texto bbcode($datos[contenido]);
$texto php($datos[contenido]);
$cat $datos[categoria];
$com $datos[comentarios];
$joas mysql_query("SELECT id, avatar FROM users WHERE id='$id'"); // hago la consulta a la tabla users para extraer el avatar
$row mysql_fetch_array($joas);
$img $row[avatar]; 
echo 
'<table width="600" border="0" cellspacing="0" cellpadding="0">
  <tr> 
    <td height="65" valign="bottom" class="indice"><font size="3"><strong><a class="link4" href="foroscat.php">Foros</a> -  
      Categoría: <font color="#487baf">'
.$cat.'</font></strong></font></td>
  </tr>
</table><br />
<table width="600" border="0" cellpadding="0" cellspacing="1" bgcolor="#ffffff">
<tr>
<td colspan="2" style="border: 1px solid #e0e0e0; padding: 5px;"><b><font size="3">'
.$datos[titulo].'</font></b></td>
</tr>
<tr><td colspan="2" bgcolor="#f8f8f8" style="border: 1px solid #e0e0e0; padding: 3px;"><img src="images/user.gif"> Enviado por <a class="link4" href=perfil.php?id='
.$datos[idautor].'><b>'.$datos[autor].'</b></a> el <b>'.$fecha.'</b> - visto: <b>'.$num.'</b> veces.</td></tr>
<tr><td style="border: 1px solid #e0e0e0; padding-top: 5px;" valign="top" width="100" align="center"><img src='
.$img.' style="border: 1px solid #000000;"></td><td width="500" style="border: 1px solid #e0e0e0;"><div class="cuerpo">'.$texto.'</div></td></tr>
</table>'
;
 }
?>
el problema ke tengo es ke solo me muestra el avatar en el primer post ke hice o sea en foro.php?id=1 y en los otros posts ke inicie no se muestra, a ke se debe eso?? hay algun error en el codigo??, espero ke me ayuden a solucionarlo, gracias y saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:42.