Foros del Web » Programando para Internet » PHP »

Problema con campos FILE dinamicos

Estas en el tema de Problema con campos FILE dinamicos en el foro de PHP en Foros del Web. Buenas amigos, estoy generando campos "file" dinamicos, para subir varias imagenes a la vez a un directorio X. Dentro del formulario hay mas campos de ...
  #1 (permalink)  
Antiguo 13/01/2006, 12:53
 
Fecha de Ingreso: octubre-2003
Mensajes: 304
Antigüedad: 14 años, 1 mes
Puntos: 0
Exclamación Problema con campos FILE dinamicos

Buenas amigos, estoy generando campos "file" dinamicos, para subir varias imagenes a la vez a un directorio X. Dentro del formulario hay mas campos de otros tipos, el problema es que al enviar el formulario todos los campos (text, textarea, etc.) llegan correctamente al procesador, pero los campos file no me llegan. A continuación el script que uso:

Código PHP:

for($i=1$i<=10$i++){echo'<input name="image'.$i.'" type="file">';}; 
la etiqueta "form" que uso es la siguiente:

Código HTML:
<form action="index2.php" method="POST" enctype="multipart/form-data" name="formulario"> 
Las variables las recibo con $HTTP_POST_FILES, tambien probe con $_POST pero no pasa nada con ninguno de los dos metodos.

Alguien sabra que problema puede estar ocurriendo???

Muchas gracias!
  #2 (permalink)  
Antiguo 13/01/2006, 12:55
AlvaroG
Invitado
 
Mensajes: n/a
Puntos:
¿podrías mostrar más código (el procesador, un ejemplo de formulario generado)?
  #3 (permalink)  
Antiguo 13/01/2006, 13:07
 
Fecha de Ingreso: octubre-2003
Mensajes: 304
Antigüedad: 14 años, 1 mes
Puntos: 0
alvlin, gracias por responder, mirá no hay demasiado que mostrar,
seria asi:
Tengo el formulario con la etiqueta:
Código HTML:
<form action="index2.php" method="POST" enctype="multipart/form-data" name="formulario"> 
luego de los campos comunes genero los campos FILE:
Código PHP:
<?

for($i=1$i<=10$i++){echo'<input name="image'.$i.'" type="file">';}; 

?>
y en el procesador (index2.php)la llegada de las variables con este script:

Código PHP:

for($i=1$i<=10$i++){
   
 echo 
$HTTP_POST_FILES['image'.$i]["name"].'.'$HTTP_POST_FILES['image'.$i]["type"].'<br>';){ 
Obtengo como resultado "Notice: Undefined variable: HTTP_POST_FILES in e:\progr....etc etc"

Muchas gracias!
  #4 (permalink)  
Antiguo 13/01/2006, 13:09
Avatar de Seppo  
Fecha de Ingreso: marzo-2005
Ubicación: Buenos Aires, Argentina
Mensajes: 1.284
Antigüedad: 12 años, 8 meses
Puntos: 17
En vez de $HTTP_POST_FILES deberías usar $_FILES
  #5 (permalink)  
Antiguo 13/01/2006, 13:13
AlvaroG
Invitado
 
Mensajes: n/a
Puntos:
1.- deberías probar antes (quizás lo haces, pero de todas formas escribo porque me gusta ) que se haya subido el archivo, con is_uploaded_file().

2.- Probando algunos sitios de forma local, me ha pasado lo mismo. Pero luego al subir el programa a internet el problema desaparecía. Puede ser tema de configuración de Apache. ¿estás probando de forma local o en internet?

Pruébalo en Internet y si el error sigue, pos creo que deberías enviar los códigos completos, porque no parece haber errores en los que envías.


Saludos.
  #6 (permalink)  
Antiguo 13/01/2006, 13:30
 
Fecha de Ingreso: octubre-2003
Mensajes: 304
Antigüedad: 14 años, 1 mes
Puntos: 0
Gracias Seppo y Alvlin, voy a probar sus consejos, despues les cuento. Estoy trabajando en forma local, quizas es eso!
  #7 (permalink)  
Antiguo 18/01/2006, 08:25
 
Fecha de Ingreso: octubre-2003
Mensajes: 304
Antigüedad: 14 años, 1 mes
Puntos: 0
Buenas, me resulto combinando las dos soluciones (probe online y use $_FILES). Muchas gracias!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:06.