Foros del Web » Programando para Internet » PHP »

problema con cookie

Estas en el tema de problema con cookie en el foro de PHP en Foros del Web. Buenas, resulta que quiero copiar una cookie que crea mi foro en cgi con una cookie de un programa en php. O sea quiero que ...
  #1 (permalink)  
Antiguo 02/07/2004, 11:49
 
Fecha de Ingreso: abril-2004
Mensajes: 310
Antigüedad: 13 años, 7 meses
Puntos: 0
problema con cookie

Buenas, resulta que quiero copiar una cookie que crea mi foro en cgi con una cookie de un programa en php. O sea quiero que en mi programa en php se genere una cookie que "cuele" en el foro, que valga el registro en mi aplicación con el registro en el foro. Pero no lo consigo. La función del Foro en cgi que crea la cookie es:

Código:
             $yySetCookies1 = cookie(-name    =>   "$cookieusername",
				-value   =>   "",
				-path    =>   "/",
				-expires =>   "Thursday, 01-Jan-1970 00:00:00 GMT");
	$yySetCookies2 = cookie(-name    =>   "$cookiepassword",
				-value   =>   "",
				-path    =>   "/",
				-expires =>   "Thursday, 01-Jan-1970 00:00:00 GMT");
Y mi funcion en php es:

Código:
  $expire = time()+7776000;
  $passc = crypt($pass);

	$yySetCookies1 = setcookie(username,$name,$expire,"/","www.misitio.com");
    $yySetCookies1 = setcookie(password,$passc,$expire,"/","www.misitio.com");
La cookie que genera mi función en php sólo es igual en los campos en negrita y el número de elementos o de líneas es el mismo:

username
minombre
wwwmisitio.com/
1024
3440222232
29632456
3593976456
29646756
*
password
%241%24gciRtJzB%24FkYMnm%2FWWStehbZeXXZe8.
wwwmisitio.com/
1024
3440222232
29632456
3593976456
29646756
*

La función del foro que se encarga de leer la cookie creo que es esta:
Código:
             sub LoadCookie {
	foreach (split(/; /,$ENV{'HTTP_COOKIE'})) {
		$_ =~ s/%([a-fA-F0-9][a-fA-F0-9])/pack("C", hex($1))/eg;
		($cookie,$value) = split(/=/);
		$yyCookies{$cookie} = $value;
	}
	if($yyCookies{$cookiepassword}) {
		$password = $yyCookies{$cookiepassword};
		$username = $yyCookies{$cookieusername} || 'Guest';
	} else {
		$password = '';
		$username = 'Guest';
	}
}
Así que nada a ver si ssabéis cómo conseguirlo.

Última edición por apañero; 02/07/2004 a las 11:54
  #2 (permalink)  
Antiguo 02/07/2004, 12:05
 
Fecha de Ingreso: abril-2004
Mensajes: 310
Antigüedad: 13 años, 7 meses
Puntos: 0
vale he encontrado la solución, el problema era efectívamente en la función crypt que había que ponerle crypt($pass,yy); no sé por qué
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:06.