Foros del Web » Programando para Internet » PHP »

Problema con Easyphp

Estas en el tema de Problema con Easyphp en el foro de PHP en Foros del Web. Saludos..., llevaba bastante tiempo usando el Easyphp en su versión 1.5 y no me había tomado la molestia en actualizarlo ya que de momento cumplía ...
  #1 (permalink)  
Antiguo 07/11/2005, 14:31
 
Fecha de Ingreso: septiembre-2004
Mensajes: 8
Antigüedad: 13 años, 2 meses
Puntos: 1
Problema con Easyphp

Saludos..., llevaba bastante tiempo usando el Easyphp en su versión 1.5 y no me había tomado la molestia en actualizarlo ya que de momento cumplía con la finalidad requerida..., pero en estos días al haber formateado mi PC me da por probar la versión más reciente de dicho programa, ya habiendo instalado la 1.8 veo que me dan muchos errores "Notice: Undefined variable" en mis scripts, luego me tomo la tarea de leer las FAQ de dicho programa y la respuesta que me detalla es referente a las variables superglobales a partir del PHP 4.2.0, sin embargo, me pongo a revisar y veo que el Easyphp 1.8 trabaja con el PHP 4.3.10 y luego revisando con qué PHP trabaja mi proveedor de hosting y veo que utiliza el 4.3.9; pero mi incomodidad radica en que en el server de mi proveedor no detalla tal error, mientras que usando el programa sí me los refiere y de paso no me ejecuta ningún script..., alguna sugerencia al respecto???
No quisiera ponerme a cambiarle las variables a cuanto código haya hecho, preferiría no tener que pensar que he perdido mi tiempo cuando mis códigos sí me están funcionando en el hosting...

Gracias de antemano por sus respuestas...
  #2 (permalink)  
Antiguo 07/11/2005, 14:56
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Lee esta FAQ:
http://www.forosdelweb.com/showthrea...988#post238988

Y esta:
http://www.forosdelweb.com/showthrea...989#post238989

Despues .. por tu compatibilida .. usa los arrays superglobales que ahí se detallan:

$_GET, $_POST .. etc en tus acceso a variables externas a tus scripts.

Un saludo,
  #3 (permalink)  
Antiguo 07/11/2005, 15:43
 
Fecha de Ingreso: septiembre-2004
Mensajes: 8
Antigüedad: 13 años, 2 meses
Puntos: 1
Ya resolví el inconveniente..., parte de la solución me la diste tú cluster..., sería hacer lo siguiente:

En el archivo de configuración PHP.INI se debe colocar en las variables:
register_globals = On
error_reporting = E_COMPILE_ERROR|E_ERROR|E_CORE_ERROR

al habilitar estas variables me evité el trabajo de estar agregándole las variables globales a todos mis códigos..., el tiempo es valioso, aunque de ahora en adelante comenzaré a usar las variables globales para evitar que me suceda algo semejante en el futuro..., gracias por tu ayuda cluster!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:39.