Foros del Web » Programando para Internet » PHP »

Problema con envio de email

Estas en el tema de Problema con envio de email en el foro de PHP en Foros del Web. Hola Tengo el siguiente problema: me respondee una señal de error desconocido cuando envio un email con la funcion mail(), al parecer no reconoce al ...
  #1 (permalink)  
Antiguo 14/05/2003, 14:55
 
Fecha de Ingreso: mayo-2003
Mensajes: 7
Antigüedad: 14 años, 6 meses
Puntos: 0
Problema con envio de email

Hola

Tengo el siguiente problema: me respondee una señal de error desconocido cuando envio un email con la funcion mail(), al parecer no reconoce al destinatario, pues este proviene de una variable, esta es la forma en que lo tengo:

$email=$_POST["email"];
...
mail($email,$asunto,$cuerpo,$headers);

Si alguien sabe algo agradezco su respuesta
Gracias
  #2 (permalink)  
Antiguo 14/05/2003, 15:35
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

¿Y la funcion mail() te funciona perfectamente si pones $email="[email protected]"; , es decir, con una direccion? Haz un echo $_POST['email']; para ver si la direccion de email el correcta. Busca en el foro, se ha comentado varias veces el codigo para validar una direccion de email.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 14/05/2003, 16:46
 
Fecha de Ingreso: mayo-2003
Mensajes: 7
Antigüedad: 14 años, 6 meses
Puntos: 0
Hola

Probé también con asignar directamente el correo. Tanto en la variable como en la funcion Ej. mail("[email protected]",...) y me genera el mismo error, sin enviar ningún correo. Trabajo en Windows XP, utilizo el servidor apache, la variable $email funciona bien pues almaceno su contenido en una base de datos y ahí aparece el correo.
Pensé que podría ser que la funcion no sea reconocida, pero al parecer el php la debería reconocer automaticamente, porque incluso el editor (Php editor) la reconoce.
Voy a seguir tu consejo y buscaré en el foro otros problemas similares
Gracias

Hola de nuevo

He estado averiguando y me encontré con las funciones IMAP, que no se que es lo que son. Si saben algo de ellas expliquenme por favor, pues ahí existe un string llamado imap_mail() que hacec lo mismo que el mail(), pero que necesita ina instalación adicional y una compilación. Será prudente hacer esta prueba o es innesesario?

Atte
  #4 (permalink)  
Antiguo 14/05/2003, 17:58
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Bien, ¿tienes configurado el servidor SMTP en tu Windows o usas un servidor externo (por ejemplo, el de tu ISP? ¿Has configurado en el php.ini los valores correspondientes? Creo que no, porque por lo que comentas es que la funcion mail() no se conecta al servidor SMTP.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #5 (permalink)  
Antiguo 14/05/2003, 18:20
 
Fecha de Ingreso: mayo-2003
Mensajes: 7
Antigüedad: 14 años, 6 meses
Puntos: 0
Pregunta

Hola

Ahí si que quedé pillo. Lo que tengo en el Php.ini es lo siguiente:

[mail function]
SMTP=mail.btinternet.com
[email protected]

No se si estará bien. Uso el Outlook Express, tengo varias cuentas. Sobre el servidor SMTP de mi Windows, aclarame si eso es diferente de las configuraciones SMTP de los correos o no?

A propósito, el mensaje de error es : Warning: Unknown error

Que estoy haciendo mal?
  #6 (permalink)  
Antiguo 14/05/2003, 21:46
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Estas seguro que ese SMTP (servidor de correo "saliente") no requiere autentificación para enviar e-mail? .. osese, que te autentifiques por SMTP (con el mismo usuario/password que usas para el POP (bajar correo)) o que requiera usar "POP" antes de enviar e-mail ..

Te lo comento porqué cada día quedan menos servicios (ISP's) que den SMTP sin autentificación para evitar que hagas mal uso (SPAM) ..

Yo para windows uso mi propio servidor SMTP y así no depende del de mi ISP (que tiene las restricciones de uso que te he comentado):

QK SMTP server
www.qksoft.com


Un saludo,

pd: .. probé tu SMTP de tu ISP y me rechazó la conexión .. "No se pudo conectar al servidor .. "
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #7 (permalink)  
Antiguo 16/05/2003, 17:48
 
Fecha de Ingreso: mayo-2003
Mensajes: 7
Antigüedad: 14 años, 6 meses
Puntos: 0
Hola

Si la requiere, no lo se con certeza. He probado con diferentes correos como predeterminados ( Dado que tengo varias cuentas e identidades diferentes) y el resultado es el mismo. Según entendí, ¿debería especificar el correo del remitente? es decir, ¿el mio?
Ahora bien, ¿la configuración del Php.ini es correcta? ¿existe vida inteligente en el universo? estoy preguntando mucho.

Se supone que esto debería subirlo a un servidor (un host), ahí la configuración del correo no debería ser relevante. como prueba final voy a probar si funciona en Windows 98 que tiene instalado el apache como servidor. Pues el XP siempre me tiene alguna sorpresa. Según resulte o continue el mismo error les comunico para ver si me pueden ayudar.

Gracias por su paciencia
  #8 (permalink)  
Antiguo 16/05/2003, 18:04
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Instalate ese servidor SMTP que te recomendé .. usa en "SMTP= localhost" (en el php.ini en ese apartado) .... lo pruebas y nos comentas ...

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #9 (permalink)  
Antiguo 19/05/2003, 15:18
 
Fecha de Ingreso: mayo-2003
Mensajes: 7
Antigüedad: 14 años, 6 meses
Puntos: 0
Hola

Instalé el SMTPserver que me recomendante, pero hasta ahora no hay cambio, me sigue dando el error referido (Warning: Unknown error in c:\sitio\foxserv\www\ins.php on line 148
). Por si las dudas esto es lo que estoy enviando:

$destinatario = $email;
$asunto = "Inscripcion";
$cuerpo ='<html>
<head>
<title>Inscripción</title>
</head>
<body>
<p>
Agradecemos su incorporación
</p>
</body>
</html>';
mail($destinatario,$asunto,$cuerpo);

Todas las variables estan confirmadas en cuanto a su contenido. En el Php.ini tengo lo siguiente:

[mail function]
SMTP=localhost
[email protected]calhost

Aun no lo pruebo en el otro computador.

Acepto todo tipo de sugerencias
Gracias

Un añadido

Mirando en el foro vi un tema similar sobre el Server Smtp, mi duda es la siguiente. ¿Es posible que mi problema tenga que ver con la version del Php que uso, la cual es PHP Version 4.2.1?
Y si así fuese, cómo puedo cambiarla sin alterar la configuración de mi server apache? (Como recién estoy en esto les confieso que lo instale todo con el programita Foxserv, de hecho tengo el php-4.3.1-Win32.zip y el php-4.3.1-installer.exe pero no me atrevo a instalarlo así como así no más)

Alguna idea?
  #10 (permalink)  
Antiguo 19/05/2003, 16:14
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Sobre ese error .. Si no nos indicas cual es la línea 148 de tu ins.php .. no queda claro que lo puede producir ...

Por otro lado. No puedes enviar ese "cuerpo" en HTML sin usar las cabeceras adecuadas para que se interprete como HTML y no como simple texto plano ..

Visita el manual de PHP oficial .. seccion "mail()" .. y haz el ejemplo que hay sale (por lo menos para probar mail() en tu servidor)

http://www.php.net/manual/en/function.mail.php

Si quieres instalar una versión mas actualizada de PHP "a mano" puedes seguir esta guía de instalación:

http://www.maestrosdelweb.com/editor...php?phpmysqlap

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #11 (permalink)  
Antiguo 22/05/2003, 01:29
 
Fecha de Ingreso: mayo-2003
Mensajes: 7
Antigüedad: 14 años, 6 meses
Puntos: 0
Hola

La linea 148 es la funcion mail(), sobre el cuerpo ya estoy trabajando en ello. Gracias

apenas tenga novedades les cuento

Mangazo
  #12 (permalink)  
Antiguo 22/05/2003, 04:56
xup
 
Fecha de Ingreso: abril-2003
Mensajes: 15
Antigüedad: 14 años, 8 meses
Puntos: 0
perdonar mi ignorancia por si digo una tonteria...
yo utilizaba tambien una cuenta que tenia en el outlook... y el envío de emails me funcionaba solo si tenia dicho programa abierto, sino me daba error...

apa! saludos!
__________________
;-)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:38.