Foros del Web » Programando para Internet » PHP »

Problema con función include()

Estas en el tema de Problema con función include() en el foro de PHP en Foros del Web. Hola, tengo un problema a la hora de trabajar con php. Estoy trabajando en local con un servidor apache, instalado mediante la aplicación AppServ. Tengo ...
  #1 (permalink)  
Antiguo 12/04/2007, 15:37
Avatar de marioraja  
Fecha de Ingreso: abril-2007
Mensajes: 66
Antigüedad: 12 años, 8 meses
Puntos: 0
Problema con función include()

Hola, tengo un problema a la hora de trabajar con php. Estoy trabajando en local con un servidor apache, instalado mediante la aplicación AppServ.

Tengo un div en donde incluyo un include a la página "cabecera.php". Utilizo el siguiente código:

<div id="cabecera"><?= include("modulos/cabecera.php"); ?></div>

El código de la página cabecera.php es:

<?php
echo '<ul><li>Actualizaciones diarias</li></ul>';
?>

Mediante un archivo css externo le doy diseño al sitio.

El problema es que me imprime el carácter "1", saliendo en pántalla:

Actualizaciones diarias1

Sin embargo, ese "1" sale por las buenas y sin razón aparente. Además de que hace que no me fundione el código css. Intento centrar el contenido del div, pero no funciona.

Cuando quito el include del div desaparece el problema; quedando el código así:

<div id="cabecera"><ul><li>Actualizaciones diarias</li></ul></div>

La cuestión es que necesito hacer el include para centralizar la edición del contenido de ese div para todas las páginas del sitio.

Espero que alguien pueda ayudarme. Gracias.
  #2 (permalink)  
Antiguo 12/04/2007, 16:50
okram
Invitado
 
Mensajes: n/a
Puntos:
Re: Problema con función include()

Prueba quitando el igual:

Código PHP:
<?php include("modulos/cabecera.php"); ?>
Si no es la solucion a tu problema, postea el contenido HTML enviado al navegador

Un saludo,
  #3 (permalink)  
Antiguo 12/04/2007, 21:33
Avatar de McBlink  
Fecha de Ingreso: noviembre-2006
Ubicación: $ARG->LaPampa()
Mensajes: 1.694
Antigüedad: 13 años
Puntos: 23
Re: Problema con función include()

De seguro que es eso.. ya que no lleva el include u igual antes.. asi te deberia funcionar..
saludos!
MC
__________________
Recuerda usar el highlight para mostrar código
mauricioblint.com
  #4 (permalink)  
Antiguo 13/04/2007, 07:01
Avatar de marioraja  
Fecha de Ingreso: abril-2007
Mensajes: 66
Antigüedad: 12 años, 8 meses
Puntos: 0
Re: Problema con función include()

AHHH es verdad! El operador = va ser lo que haga imprimir ese uno raro. Desde luego vaya lapsus. Gracias, voy a probarlo y os cuento a ver si se soluciona el problema.

Estoy seguro de que si; muchas gracias. Hasta luego, ahora os cuento.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:01.