Foros del Web » Programando para Internet » PHP »

problema con funcion include

Estas en el tema de problema con funcion include en el foro de PHP en Foros del Web. hola tengo el siguente problema necesito incluir un codigo php en mi pagina , lo normal es usar include("codigo.php") , todo funciona bien cuando esta ...
  #1 (permalink)  
Antiguo 20/07/2002, 16:40
Avatar de goya  
Fecha de Ingreso: enero-2002
Ubicación: La Serena
Mensajes: 273
Antigüedad: 15 años, 10 meses
Puntos: 1
problema con funcion include

hola

tengo el siguente problema necesito incluir un codigo php en mi pagina , lo normal es usar include("codigo.php")
, todo funciona bien cuando esta en el mismo directorio , el problema es que este codigo esta en otro sitio y cuando pongo include("http://www.miotrositio.com/codigo.php")
me aparece un error

Warning: Failed opening 'http://localhost/test/codigo.php' for inclusion (include_path='') in c:\archivos de programa\apache group\apache\htdocs\ej_php\formula2.php on line 10

las lineas de mi paguina son estas

9 <?php
10 include("http://localhost/test/codigo.php");
11 ?>

que esta mal ???

ps. probe con $fp = fopen("http://localhost/test/libreria.php", "r"); y tampoco funciono

salu2

Visita Astrochile <a href="www.astrochile.550m.com">www.astrochile.550m .com </a>
  #2 (permalink)  
Antiguo 20/07/2002, 17:57
Avatar de José Molina  
Fecha de Ingreso: enero-2002
Ubicación: USA
Mensajes: 768
Antigüedad: 15 años, 11 meses
Puntos: 1
Re: problema con funcion include

Saludos

Cuando quieres colocar includes de esa manera debes tener la ruta fisica del archivo por ejemplo:

/var/www/html/nombre_carpeta/nombre_archivo

o

home/nombre_carpeta/nombre_archivo

todo depende del servidor donde estes conectado.

Si haces un php de prueba y ejecutas el phpinfo podrás ver la ruta requerida.

phpprueba.php =

&lt;?
echo phpinfo();
?&gt;

Espero te sirva de algo.

José Molina
  #3 (permalink)  
Antiguo 20/07/2002, 23:11
Avatar de goya  
Fecha de Ingreso: enero-2002
Ubicación: La Serena
Mensajes: 273
Antigüedad: 15 años, 10 meses
Puntos: 1
Re: problema con funcion include

el problema es que mis codigos estan en 1 hosting y las paginas en otro :(

Visita Astrochile <a href="www.astrochile.550m.com">www.astrochile.550m .com </a>
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:13.