Foros del Web » Programando para Internet » PHP »

Problema con getimagesize antes funcionaba

Estas en el tema de Problema con getimagesize antes funcionaba en el foro de PHP en Foros del Web. Hola amigos estoy usando el getimagesize todo funcionaba bien y el día de hoy jueves - 3 de agosto el sistema me empezo a marcar ...
  #1 (permalink)  
Antiguo 03/08/2006, 13:42
Avatar de chalchis  
Fecha de Ingreso: julio-2003
Mensajes: 1.773
Antigüedad: 14 años, 4 meses
Puntos: 21
Problema con getimagesize antes funcionaba

Hola amigos estoy usando el getimagesize
todo funcionaba bien y el día de hoy jueves - 3 de agosto
el sistema me empezo a marcar estos errores

Warning: getimagesize(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439

Warning: getimagesize(http://www.cuhm.mx/Imagen/Insumos_img/1.gif): failed to open stream: Resource temporarily unavailable in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439
Solicitado
Warning: getimagesize(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439

Warning: getimagesize(http://www.cuhm.mx/Imagen/Insumos_img/2.gif): failed to open stream: Resource temporarily unavailable in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439
Autorizado
Warning: getimagesize(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439

Warning: getimagesize(http://www.cuhm.mx/Imagen/Insumos_img/3.gif): failed to open stream: Resource temporarily unavailable in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439
Esperando surtido
Warning: getimagesize(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439

Warning: getimagesize(http://www.cuhm.mx/Imagen/Insumos_img/4.gif): failed to open stream: Resource temporarily unavailable in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439
Pendiente de entregar
Warning: getimagesize(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439

Warning: getimagesize(http://www.cuhm.mx/Imagen/Insumos_img/5.gif): failed to open stream: Resource temporarily unavailable in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439
Entregado
Warning: getimagesize(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439

Warning: getimagesize(http://www.cuhm.mx/Imagen/Insumos_img/6.gif): failed to open stream: Resource temporarily unavailable in /var/www/sitios/cuhm.mx/www/htdocs/Php/reporte_insumos.php on line 439
Cancelado

que sera ya reinicie el servicio de apache
y sigue igual

saludos espero sus comentarios

este es el codigo

if(file_exists($web.$imagenes."Insumos_img/".$rowdepicono[0].".gif"))
{
$pixeles=getimagesize($raiz.$imagenes."Insumos_img/".$rowdepicono[0].".gif");
echo '<img src="../Imagen/Insumos_img/'.$rowdepicono[0].'.gif" width="'.$pixeles[0].'" height="'.$pixeles[1].'" border="0">'.$rowdepicono[1].'&nbsp;&nbsp;';
}
__________________
gerardo
  #2 (permalink)  
Antiguo 03/08/2006, 15:48
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
El error: "failed to open stream: Resource temporarily unavailable" .. textualmente no dice que que el error sea definitivo .. ahí dice "temporal".

Si dices que te funcionó dicho código .. asumimos que usas "allow_fopen" a ON .. (es decir, en PHP permites accesos remotos a archivos por http:// y otros "wrappers").

Estás seguro que ese URL funciona?

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 03/08/2006, 15:53
Avatar de chalchis  
Fecha de Ingreso: julio-2003
Mensajes: 1.773
Antigüedad: 14 años, 4 meses
Puntos: 21
no hubo problemas durante 3 meses

Cuando libere el proyecto no habia problemas si no de repente hoy a 3/agosto/06 empezo a mostrar esos errores y efectivamente allow_fopen esta en "On"

no se que pueda ser :
Ya reinice el apache solo faltaria reiniciar el servidor donde esta hospedado todo el sistemita

saludos y gracias por la ayuda
__________________
gerardo
  #4 (permalink)  
Antiguo 03/08/2006, 16:09
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
Iniciado por chalchis
Cuando libere el proyecto no habia problemas si no de repente hoy a 3/agosto/06 empezo a mostrar esos errores y efectivamente allow_fopen esta en "On"

no se que pueda ser :
Ya reinice el apache solo faltaria reiniciar el servidor donde esta hospedado todo el sistemita

saludos y gracias por la ayuda
Yo miraría mejor esos URL's .. imagina que esas imagenes estén protegidas bajo alguna ténica "anti-lech" (para que no vincules las imagenes en forma remota .. sólo local) ..

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #5 (permalink)  
Antiguo 03/08/2006, 16:20
Avatar de chalchis  
Fecha de Ingreso: julio-2003
Mensajes: 1.773
Antigüedad: 14 años, 4 meses
Puntos: 21
Sonrisa listo cluster

Gracias cluster por alguna razon el dns del servidor no estaba actualizado
y eso se debio aque el servidor primario de lo dns estuvo fuera de linea
ya me comunique con el jefe de del departamento ya probe el sistema
y ya camina muy bien lo que se hizo es hacer un reboot y cambiar un ip del nuevo
servidor primario de dns.



gracias por la ayuda
__________________
gerardo

Última edición por chalchis; 03/08/2006 a las 16:29
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:13.