Foros del Web » Programando para Internet » PHP »

Problema con Gettext

Estas en el tema de Problema con Gettext en el foro de PHP en Foros del Web. Hola, creo que lo que relato finalmente podría ser un fallo de configuración de gettext. Pues tengo un problema que me está volviendo loco y ...
  #1 (permalink)  
Antiguo 13/09/2012, 10:02
 
Fecha de Ingreso: junio-2004
Mensajes: 57
Antigüedad: 18 años, 2 meses
Puntos: 0
Problema con Gettext

Hola, creo que lo que relato finalmente podría ser un fallo de configuración de gettext.

Pues tengo un problema que me está volviendo loco y quisiera ver si alguien podia indicar el camino ya que yo por mas vueltas que le doy... no lo veo.

He introducido la internacionalización a una pagina de 40 idiomas, todos van perfectos excepto 4 y 3 de ellos se leen de derecha a izquierda (arabe, urdu y... hebreo).

¿El problema cual es? Pues que si yo le digo al gettext que coja algun idioma de estos, la web muestra el nombre de las variables del gettext sin mas, pero ahora viene lo mejor de todo.
Si yo cojo el .mo (arabe) y lo llevo a una carpeta de ... por ejemplo ingles (idioma que se ve perfectamente desde el princpio), posteriormente en el selector pulso el ingles, veo la pagina perfectamente en árabe.

Se que visto así ... parece una tonteria, pero he revisado todo 100 veces, los permisos etc, todo esta igual, pero no funciona y uff, acaba saturando ya.

Agradecería cualquier ayuda.

Un saludo

Etiquetas: gettext
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:08.