Foros del Web » Programando para Internet » PHP »

Problema con header

Estas en el tema de Problema con header en el foro de PHP en Foros del Web. Tengo una página con un formulario que al apretar el botón se envia a otra página PHP para que procese los datos. en procesar.php tengo, ...
  #1 (permalink)  
Antiguo 06/10/2003, 07:57
 
Fecha de Ingreso: julio-2002
Mensajes: 72
Antigüedad: 15 años, 4 meses
Puntos: 0
Problema con header

Tengo una página con un formulario que al apretar el botón se envia a otra página PHP para que procese los datos.

en procesar.php tengo,


<?
require('connexion.php');

if($modificar==1)
{

@$consulta=mysql_query("INSERT INTO campe (ID,campt) VALUES (NULL,'$campt')");
require("failure.php");
header("location: admin.php");
exit;
}

...
...
...


?>

todo funciona bien, excepto que no se me redirecciona a admin.php, que es la página principal (está en el mismo directorio de procesar.php). No sale ningun error, ni nada, la página se queda en blanco.

¿Que hago mal?

He seguido un ejemplo de un tutorial.
  #2 (permalink)  
Antiguo 06/10/2003, 08:00
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Antes del header no debes enviar ninguna salida al navegador. Ni codigo HTML, ni echo, ni espacios en blanco. Asegurate que en los ficheros que incluyes no haya ningun espacio en blanco despues de ?>.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:37.