Foros del Web » Programando para Internet » PHP »

Problema con headers en WML o configuracion del servidor?

Estas en el tema de Problema con headers en WML o configuracion del servidor? en el foro de PHP en Foros del Web. Hola a todos! mi consulta se debe a que estoy haciendo un sitio para telefonos wap y no logro que algunos telefonos me presenten las ...
  #1 (permalink)  
Antiguo 21/09/2005, 10:00
 
Fecha de Ingreso: enero-2005
Mensajes: 89
Antigüedad: 12 años, 10 meses
Puntos: 0
Pregunta Problema con headers en WML o configuracion del servidor?

Hola a todos!
mi consulta se debe a que estoy haciendo un sitio para telefonos wap y no logro que algunos telefonos me presenten las paginas en php.
Lo que he probado es hacer un php como el siguiente

Código PHP:
<?php
header
("Content-type: text/vnd.wap.wml"); 
print 
"<?xml version=\"1.0\"?>";
print 
"<!DOCTYPE wml PUBLIC \"-//WAPFORUM//DTD WML 1.1//EN\" \"http://www.wapforum.org/DTD/wml_1.1.xml\">";
?>
<wml>
<card id="card1" title="">
<p>
<small>
Texto de prueba
</small>
</p>
<do type="prev" label="Volver">
<prev/>
</do>
</card> 
</wml>
y cuando visualizado el archivo .php que contiene este codigo me figura un error como que el contenido no tiene soporte.

Luego probe hacer lo siguiente. Realize un archivo .wml que es asi:

Código:
 
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN" "http://www.wapforum.org/DTD/wml_1.1.xml"> 
<wml>
<card id="card1" title="">
<p>
<small>
Texto de prueba
</small>
</p>
<do type="prev" label="Volver">
<prev/>
</do>
</card> 
</wml>
lo accedi desde el telefono y efectivamente se presento el texto en pantalla. Luego, renombre el archivo .wml a .php y cuando lo quiero acceder desde el telefono me figura nuevamente un error como que el tipo de datos es incorrecto.
Estas pruebas las estoy haciendo desde el servidor que tengo contratado, q aparentemente envia correctamente los archivos .wml para que los telefonos lo interpreten, pero los archivos en PHP no funcionan.
Sabe alguien que cabeceras puedo utilizar en el archivo en .php para que el telefono considere que esta recibiendo informacion wml? o, que se debe modificar en el servidor para que considere que el php contiene informacion para el celular?

bueno, espero que me puedan ayudar con esto, ya que estoy bastante desesperado, no entiendo bien que es lo que ocurre...

Saludos a todos!
__________________
Diegote ::.

www.mmsolutions.com.ar
  #2 (permalink)  
Antiguo 22/09/2005, 07:11
 
Fecha de Ingreso: enero-2005
Mensajes: 89
Antigüedad: 12 años, 10 meses
Puntos: 0
He probado con algunos emuladores y las paginas se ven perfectas, pero pruebo en los telefonos y me da error
__________________
Diegote ::.

www.mmsolutions.com.ar
  #3 (permalink)  
Antiguo 22/09/2005, 07:48
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Revisa este artículo ..

http://www.phpbuilder.com/columns/mike20010118.php3

Ahí veras por ejemplo como añadir la extensión .wml para que sea interpretada por PHP .. así podrás incrustrar PHP sobre .wml y otros detalles.

También revisa la configuración de PHP sobre (php.ini):
short_open_tag

Normalmente está a ON .. lo cual hace que puedas inciar PHP diciendo simplemente:
<?

pero eso dá problemas cuando usas XML por qué este también empieza con <? .. así que para diferenciar expresamente lo que es PHP y XML .. lo dejas a OFF y tendrás que usar siempre: <?php cuando hagas referencia a PHP (y <?xml .. cuando lo hagas para XML)

Un saludo,
  #4 (permalink)  
Antiguo 22/09/2005, 08:31
 
Fecha de Ingreso: enero-2005
Mensajes: 89
Antigüedad: 12 años, 10 meses
Puntos: 0
Muchas gracias! voy a probarlo a ver si funciona, cualquier cosa vuelvo jeje

Saludos!!!
__________________
Diegote ::.

www.mmsolutions.com.ar
  #5 (permalink)  
Antiguo 22/09/2005, 10:21
Avatar de FuLaNo_  
Fecha de Ingreso: mayo-2003
Ubicación: Don Torcuato, Buenos Aires, Argentina
Mensajes: 1.250
Antigüedad: 14 años, 6 meses
Puntos: 2
el problema debe ser la extensión del archivo... yo tengo creada una regla con mod_rewrite para acceder a archivo.wml cuando en verdad es archivo.php, esto hace que muchos celulares dejen de dar error.

Mi archivo es así:

Código PHP:
<?php header("Content-Type: text/vnd.wap.wml");
echo 
'<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN" " http://www.wapforum.org/DTD/wml_1.1.xml">
<wml>
<card id="homeNews" title="Noticias">
<p>
'
;
include(
"../includes/db.php");
$_SQL mysql_query("SELECT * FROM noticias ORDER BY id DESC LIMIT 0,5");
while(
$_ROW=mysql_fetch_assoc($_SQL)) {
$_TITLE str_replace('"',""",$_ROW["titulo"]);
$_TITLE substr($_TITLE030);
echo 
'<a href="#nro'.$_ROW[id].'">'.$_TITLE.'...</a><br /><br />';
}
echo 
'</p></card>';
$_SQL mysql_query("SELECT * FROM noticias ORDER BY id DESC LIMIT 0,5");
while(
$_ROW=mysql_fetch_assoc($_SQL)) {
$_TITLE str_replace('"',""",$_ROW["titulo"]);
$_TITLE substr($_TITLE030);
$_TEXTO eregi_replace("<img([^>]+)>"""$_ROW["copete"]);
$_TEXTO eregi_replace("<a([^>]+)>"""$_TEXTO);
$_TEXTO str_replace("</a>","",$_TEXTO);
$_TEXTO str_replace("<br>","<br />",$_TEXTO);
$_TEXTO str_replace("<br/>","<br />",$_TEXTO);
echo 
'
<card id="nro'
.$_ROW[id].'" title="'.$_TITLE.'..."> 
<p>'
.$_TEXTO.'<br /><br /><a href="#homeNews">inicio</a></p>
</card>
'
;
}
echo 
'</wml>';
?>
No le des importancia a todos los replace y eregi, pues son para eliminar imagenes y demas cosas del texto que proviene de mi DB.

El archivo para la regla mod_regrite es el siguiente (esta dentro de la carpeta wap:

Código:
RewriteEngine on
RewriteBase /wap/
RewriteRule ^(index).wml$                 index.php
__________________
I Love Programming...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:40.