Foros del Web » Programando para Internet » PHP »

problema con hidden

Estas en el tema de problema con hidden en el foro de PHP en Foros del Web. Buenas, tengo un problema con un hidden. Lo que quiero hacer es poner un hidden dentro de un for, para que en cada recorrida me ...
  #1 (permalink)  
Antiguo 28/01/2008, 10:46
 
Fecha de Ingreso: diciembre-2007
Mensajes: 30
Antigüedad: 12 años
Puntos: 0
problema con hidden

Buenas, tengo un problema con un hidden.

Lo que quiero hacer es poner un hidden dentro de un for, para que en cada recorrida me genere un hidden nuevo.

Lo que quiero hacer es al name del hidden ir agregandole el valor que tiene el for
en cada momento.

seria algo asi.


for($i=0;$i<= a algo;$i++)
{?>
<input type="hidden" name="campo_<?$i?>" id="campo" value = "">
<?}

El problema esta en el hidden, cuando lo tomo con un $_REQUEST no me aparece nada, solo me aparece campo_ y nada mas.

Espero respuestas
Gracias.
  #2 (permalink)  
Antiguo 28/01/2008, 10:52
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 17 años, 9 meses
Puntos: 772
Re: problema con hidden

Hola Jarancho

Ponlo así:

Código:
<input type="hidden" name="campo_<? echo $i?>" id="campo<? echo $i?>" value = "">
Fíjate que he hecho lo mismo con el id, porque no pueden repetirse.

Saludos,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:53.