Foros del Web » Programando para Internet » PHP »

problema con un if

Estas en el tema de problema con un if en el foro de PHP en Foros del Web. tengo: formulario --> se llama a una funcion que me da resultados de la siguiente forma Código PHP:  $consulta  =( "SELECT nombre, f.codFuncion FROM funciones f, funrec fr WHERE f.codFuncion=fr.codFuncion and codRecurso=\"$comparacion\"" ); $resultado = mysql_query ...
  #1 (permalink)  
Antiguo 07/06/2005, 04:50
 
Fecha de Ingreso: abril-2005
Mensajes: 171
Antigüedad: 12 años, 7 meses
Puntos: 0
problema con un if

tengo:

formulario --> se llama a una funcion que me da resultados de la siguiente forma

Código PHP:
 $consulta =("SELECT nombre, f.codFuncion FROM funciones f, funrec fr WHERE f.codFuncion=fr.codFuncion and codRecurso=\"$comparacion\"");
$resultado=mysql_query($consulta);
while (
$datos=mysql_fetch_Array($resultado)) {
    echo(
"$datos[nombre]  
             <input type=\"hidden\" name=\"estadofun[]\" value=\"$datos[codFuncion]\"> "
); 
Mas o menos es asi ya que tiene mas opciones pero son iguales a esa.
Esto me lo muestra bien y en $datos[codFuncion] SI hay datos.

validacion--> Es la que recoge los datos de formulario, y la que me da problemas

Código PHP:
 if (isset($_POST['modificar_persona'])){ //este es el boton quese ha pulsado en formulario
             
if (isset($_POST['estadofun'])){ 
Bien pues el problema esque no me entra en el
if (isset($_POST['estadofun']))

tiene que ser un fallo con el hidden pero no lo encuentro

GRACIAS
  #2 (permalink)  
Antiguo 07/06/2005, 04:56
Avatar de jam1138
/** @package Moderador */
 
Fecha de Ingreso: julio-2004
Ubicación: sèveR led onieR lE
Mensajes: 9.368
Antigüedad: 13 años, 4 meses
Puntos: 101
Hay que leer dos veces para entenderte...
... ... ok, lo que en este caso importa es tu resultado final. ¿cómo se presenta tu código fuente??.. quiero suponer te aseguras de imprimir dicho elemento hidden dentro de las etiquetas <form> y </form>...
__________________
٩(͡๏̯͡๏)۶
» Cómo hacer preguntas de manera inteligente «

"100 años después, la revolución no es con armas, es intelectual y digital"
  #3 (permalink)  
Antiguo 07/06/2005, 05:13
 
Fecha de Ingreso: abril-2005
Mensajes: 171
Antigüedad: 12 años, 7 meses
Puntos: 0
SOLUCIONADO supongo que alguna comilla que fallaba.

Por cierto pues va ha ser que si estaba entre <form></form> y tan mal me expreso para que lo leas 2 veces a mi me parece bastante claro

pagina hace tal tiene esto. Y un titulo indicativo del problema

GRACIAS
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:09.