Foros del Web » Programando para Internet » PHP »

Problema con include

Estas en el tema de Problema con include en el foro de PHP en Foros del Web. Bueno no se por qué pero intento incluir un archivo php y no me hace nada. Bueno, en dreamweaver si puedo ver en "vivo" que ...
  #1 (permalink)  
Antiguo 21/08/2012, 03:47
 
Fecha de Ingreso: enero-2012
Ubicación: En españa dije...
Mensajes: 28
Antigüedad: 10 años, 3 meses
Puntos: 1
Problema con include

Bueno no se por qué pero intento incluir un archivo php y no me hace nada. Bueno, en dreamweaver si puedo ver en "vivo" que se incluye pero cuando abro mi pagina en localhost no se incluye nada.

Utilizo WAMPSERVER 2.2, y he mirando en apache y dice que está operativo el módulo de include.

El código es corto, a ver si alguien puede echarme una mano.

"index.php"
Código PHP:
Ver original
  1. <html>
  2. <head>
  3. <link rel="STYLESHEET" type="text/css" href="Button.css"><title></title>
  4. </head>
  5. <body background="ZenBG.png">
  6.     <?php
  7.         include ("Menu.php");
  8.         ?>
  9. </body>
  10. </html>

"Menu.php"
Código HTML:
Ver original
  1. <table border=0 width='100%'>
  2.     <tr>
  3.         <td colspan='2'><span class='button'><a href='index.html'  style='text-decoration:none'>HOME</a></span>
  4.         </td>
  5.         <td><span class='button'><a href='http://forums.supahsonic.com/index.php?'  style='text-decoration:none' target='_blank'>FORUM</a></span>
  6.         </td>
  7.         <td><span class='button'><a href='index.html'  style='text-decoration:none'>ZZZZ</a></span>
  8.         </td>
  9.         <td><span class='button'><a href='i.html'  style='text-decoration:none'>Register</a></span>
  10.         </td>
  11.         <td colspan='2'><span class='bn'><a href='index.html'  style='text-decoration:none'>REGISTER</a></span>
  12.         </td>
  13.     </tr>

He intentado el include de todas las formas que se me han ocurrido:

Código PHP:
Ver original
  1. <?
  2.       include "Menu.php";
  3. ?>
  4. <?
  5.       include ("Menu.php");
  6. ?>
  7. <?
  8.       include ('Menu.php');
  9. ?>

Pero no me funciona ninguna.

Espero que alguien pueda ayudarme.
  #2 (permalink)  
Antiguo 21/08/2012, 04:04
 
Fecha de Ingreso: julio-2012
Ubicación: Girona
Mensajes: 63
Antigüedad: 9 años, 10 meses
Puntos: 10
Respuesta: Problema con include

prueba con
Código PHP:
Ver original
  1. <?php
  2.    include "Menu.php";
  3. ?>

Nota que en el tag de abertura he puesto <?php en vez de <? (puede que no lo tengas configurado el tag corto)

Saludos
__________________
Por favor utilizad HIGHLIGHTS en los códigos insertados para que sean más legibles
  #3 (permalink)  
Antiguo 21/08/2012, 04:12
 
Fecha de Ingreso: enero-2012
Ubicación: En españa dije...
Mensajes: 28
Antigüedad: 10 años, 3 meses
Puntos: 1
Respuesta: Problema con include

Mira que yo pensaba que había probado eso... no si... me voy a pegar un tiro en la pierna a ver si se me pasa el estrés xD.

Gracias amigo.

Etiquetas: html, include
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:53.