Foros del Web » Programando para Internet » PHP »

problema con include

Estas en el tema de problema con include en el foro de PHP en Foros del Web. Hola a todos tengo una plantilla en la que uso un include para añadir un menu, pero me da el siguiente error: Warning: main( http://www.asturnatura.com/Menus/menuplan.php ...
  #1 (permalink)  
Antiguo 28/03/2005, 06:48
 
Fecha de Ingreso: febrero-2004
Ubicación: Asturias
Mensajes: 171
Antigüedad: 13 años, 10 meses
Puntos: 0
problema con include

Hola a todos

tengo una plantilla en la que uso un include para añadir un menu, pero me da el siguiente error:

Warning: main(http://www.asturnatura.com/Menus/menuplan.php): failed to open stream: Connection timed out in /datos/home/asturnat/public_html/pruebas/untitled.php on line 9

Warning: main(): Failed opening 'http://www.asturnatura.com/Menus/menuplan.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /datos/home/asturnat/public_html/pruebas/untitled.php on line 9

probando solo con un archivo que tenga

Código HTML:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Documento sin t&iacute;tulo</title>
</head>

<body>
<? include ('http://www.asturnatura.com/Menus/menuplan.php'); ?>
</body>
</html> 
pero si ejecuto el menu solo desde esa direccion funciona perfectamente. ¿porque se produce el error entonces? me tiene bastante sorprendido

gracias
  #2 (permalink)  
Antiguo 28/03/2005, 11:04
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Haz la llamada por ruta Absoluta . .no relativa:

include("/datos/home/asturnat/public_html/Menus/menuplan.php");

De todas formas .. para el caso de obtener el "HTML/javascript/etc" generado por ese menuplan.php .. debería de funcionar como lo usas, el problema es que te dá un mensaje de tiempo máximo de acceso sobrepasado .. ¿Demora mucho tiempo en proceso ese script?

Un saludo,
  #3 (permalink)  
Antiguo 28/03/2005, 12:52
 
Fecha de Ingreso: febrero-2004
Ubicación: Asturias
Mensajes: 171
Antigüedad: 13 años, 10 meses
Puntos: 0
no entiendo porque tarda tanto como dije antes. es una simple tabla con funciones onclick, onmouseover...

de todas formas con esa ruta ya funciona perfectamente. cosa rara, pero bueno.

gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:28.