Foros del Web » Programando para Internet » PHP »

problema con <? include()?>

Estas en el tema de problema con <? include()?> en el foro de PHP en Foros del Web. Hola a todos, tengo un problema, resulta que a través de un menú que tengo en una página llamo a un javascript en el que ...
  #1 (permalink)  
Antiguo 06/03/2006, 02:49
 
Fecha de Ingreso: febrero-2002
Ubicación: Valladolid
Mensajes: 83
Antigüedad: 15 años, 10 meses
Puntos: 1
problema con <? include()?>

Hola a todos, tengo un problema, resulta que a través de un menú que tengo en una página llamo a un javascript en el que tengo el siguiente código:

str+='<a href="#" onclick="document.getElementById(\'contenido\' ).innerHTML = \'<b>hola</b>\'; "'

de esta manera lo que me hace el menú es cargarme en una celda que se llama contenido el texto hola en negrita, pero el problema está en que lo que quiero hacer yo es hacer un include de php con esta sintaxis <? include("pagina.html")?> y claro está, las comillas no funcionan


¿Hay alguna manera de hacer el include para que me funcione?
Muchas Gracias.......
  #2 (permalink)  
Antiguo 06/03/2006, 06:50
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pues usa comillas simples o las escapas:

<? include (\"pagina.html\"); ?>

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:55.