Foros del Web » Programando para Internet » PHP »

Problema con las variables de formulario tipo POST

Estas en el tema de Problema con las variables de formulario tipo POST en el foro de PHP en Foros del Web. Joe, que estoy muy quemao. Creo un formulario, tipo post, con su correspondiente fichero .php para hacer el insert. (todo esto lo he hecho sacando ...
  #1 (permalink)  
Antiguo 04/07/2002, 10:40
 
Fecha de Ingreso: julio-2002
Mensajes: 5
Antigüedad: 15 años, 5 meses
Puntos: 0
Problema con las variables de formulario tipo POST

Joe, que estoy muy quemao.
Creo un formulario, tipo post, con su correspondiente fichero .php para hacer el insert. (todo esto lo he hecho sacando el código de manuales -copy/paste, para no equivocarme). Y me dice que las variables que utilizo en el insert, que son los mismos nombre que los campos del forumulario, que no existen (me muestra un mensaje por cada variable).

No sé qué puede ser, estoy desesperado. Ayudadme por favor.
  #2 (permalink)  
Antiguo 04/07/2002, 10:52
 
Fecha de Ingreso: abril-2002
Mensajes: 1.013
Antigüedad: 15 años, 7 meses
Puntos: 8
Re: Problema con las variables de formulario tipo POST

1) Has ejecutado mysqld.exe?
2) Has abierto la BD... :P?
3) Y por qué no pones el código?
  #3 (permalink)  
Antiguo 04/07/2002, 12:29
 
Fecha de Ingreso: julio-2002
Mensajes: 5
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: Problema con las variables de formulario tipo POST

Sí he ejecutado todo lo que tenía que ejecutar.
Es más, consultar la base de datos sí puedo, e insertar si pongo la cadena directamente escrita. Lo que no puedo es recoger las variables que pase con el formulario. No es problema de la base de datos.
No sé qué hacer. . ayuda por favor.
  #4 (permalink)  
Antiguo 04/07/2002, 14:09
 
Fecha de Ingreso: junio-2002
Ubicación: BOGOTA COLOMBIA
Mensajes: 52
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: Problema con las variables de formulario tipo POST

Una vez tuve el mismo problema y lo solucione poniendo registre_globals en ON en el archivo de configuracion de php php.ini

saludos
  #5 (permalink)  
Antiguo 04/07/2002, 14:12
Avatar de goncafa  
Fecha de Ingreso: julio-2002
Ubicación: Santiago
Mensajes: 1.211
Antigüedad: 15 años, 5 meses
Puntos: 10
Re: Problema con las variables de formulario tipo POST

si pusieras el codigo seria mas facil poder ayudarte ;)


<hr noshade>
<font face="Arial" sise=1>
Gonzalo Castillo
[/CODE]
  #6 (permalink)  
Antiguo 04/07/2002, 16:28
 
Fecha de Ingreso: julio-2002
Mensajes: 1
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: Problema con las variables de formulario tipo POST

Verifica el register_globals=ON(php.ini) y la forma de recepcion de las variables en la pagina de destino. La recepcion de la variable debe ser con $.
  #7 (permalink)  
Antiguo 07/07/2002, 18:46
 
Fecha de Ingreso: julio-2002
Mensajes: 5
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: Problema con las variables de formulario tipo POST

Muchas gracias.
el problema era la variable de Globals, ya la he puesto en ON.

Con gente como vosotros todo es más fácil.

Lo dicho, muchísimas gracias. :) :) :)
  #8 (permalink)  
Antiguo 08/07/2002, 19:10
Avatar de gomo  
Fecha de Ingreso: mayo-2002
Ubicación: [email protected]
Mensajes: 906
Antigüedad: 15 años, 7 meses
Puntos: 0
Re: Problema con las variables de formulario tipo POST

a tener en cuenta: a la hora de emprender un proyecto serio con PHP, es importante programar con register_globals= off
cuando esta asi, la forma de usar las variables es tomandolas de los arrays globales que les corresponden: ,
$_POST['variable'] o $_GET['var'], dependiendo de por donde hayan llegado...
Saludos ;)


<div align="center"><img src="http://cablemodem.fibertel.com.ar/sainztrapaga/images/firma.jpg" width="435" height="70" border="0">
</div>
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:48.