Foros del Web » Programando para Internet » PHP »

Problema con links

Estas en el tema de Problema con links en el foro de PHP en Foros del Web. Hola, tengo un problema con unos links, tengo un sistema d eusuarios y esta pagina es para que vean sus amigos, el problema es que ...
  #1 (permalink)  
Antiguo 02/01/2015, 13:07
 
Fecha de Ingreso: mayo-2010
Mensajes: 185
Antigüedad: 9 años, 7 meses
Puntos: 2
Problema con links

Hola, tengo un problema con unos links, tengo un sistema d eusuarios y esta pagina es para que vean sus amigos, el problema es que en la foto de su amigo sale el link bien, peor en el nombre del amigo sale mal, ejemplo:

foto el link a donde te lleva es a pagina.com/urldelamigo
y el nombre te lleva a pagina.com/account/urldelamigo

lo que quiero es quitar la parte de account pero no se como :( les dejo el codigo aver si me pueden ayudar

Código:
<?php

    /*!
     * QAScript v1.2.0
     * http://ifsoft.com.ua
     * [email protected]
     *
     * Copyright (C) 2012-2014 Demyanchuk Dmitriy (Russian Dimon)
     */

    if (!isset($i_am))
    {
        $app->AddError(5,"friends");
        header('Location: /');
    }

    if (!empty($_POST))
    {
        $page = (isset($_POST['page'])) ? ($_POST['page']) : 0;

        $page = intval($page);

        $i_am->GetFriends($page, $TEXT);

        exit;
    }

    $css_files = array("style.css");
    $page_title = $TEXT['navi-friends'];
    $page_id = "friends";

    include_once("../html/common/header.inc.php");
?>

<body class="noface-theme">

<div id="back" class="modal-backdrop hide"></div>

    <?php
        include_once('../html/common/topbar.inc.php');
    ?>

<div id="page-outer">
    <div class="wrapper-main">
        <div class="left-sidebar">
            <div class="usermenu">
            <?php
                include_once("../html/common/leftbar.inc.php");
            ?>
            </div>
        </div>

        <div class="profile-wrapper noface">
            <div class="page-header">
            <?php
                if ($app->mobiledetect)
                {
                    ?>
                    <a onClick="history.back(); return false;" href="/<?php echo $i_am->login; ?>"><?php echo $TEXT['btn-history-back']; ?></a>
                    <?php
                }
                else
                {
                    echo $page_title;
                }
            ?>
            </div>

            <div class="questions-content">

            <?php
                if ($i_am->GetFriendsCount() > 0)
                {
                    echo $i_am->GetFriends(0, $TEXT);
                }
                else
                {
                    ?>
                    <div class="info-block">
                        <span ><?php echo $TEXT['favorites-no']; ?></span>
                    </div>
                    <?php
                }
            ?>
            </div>

        </div>

        <div class="small-footer">
            <?php
                include_once("../html/common/footer.inc.php");
            ?>
        </div>
        
    </div>
</div>
</body>
</html>
  #2 (permalink)  
Antiguo 02/01/2015, 21:50
Avatar de loncho_rojas
Colaborador
 
Fecha de Ingreso: octubre-2008
Ubicación: En el mejor lugar del mundo
Mensajes: 2.704
Antigüedad: 11 años, 1 mes
Puntos: 175
Respuesta: Problema con links

Por qué no nos indicas en que parte está haciendo eso que dices?
__________________
Ayudo con lo que puedo en el foro, y solo en el foro.. NO MENSAJES PRIVADOS.. NO EMAILS NI SKYPE u OTROS.

Antes de hacer un TOPICO piensa si puedes hallarlo en Google o en el Buscador del Foro...

Etiquetas: html, links, usuarios
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:30.