Foros del Web » Programando para Internet » PHP »

problema con mysql

Estas en el tema de problema con mysql en el foro de PHP en Foros del Web. tengo instalado apache+php5+mysql4 estoy intentando hacer funcionar una pequeña videoteca y me da el siguiente error: Fatal error: Call to undefined function mysqli_connect() in c:\www\videoteca.php ...
  #1 (permalink)  
Antiguo 06/04/2006, 05:09
 
Fecha de Ingreso: junio-2005
Mensajes: 39
Antigüedad: 12 años, 5 meses
Puntos: 0
problema con mysql

tengo instalado apache+php5+mysql4

estoy intentando hacer funcionar una pequeña videoteca y me da el siguiente error:

Fatal error: Call to undefined function mysqli_connect() in c:\www\videoteca.php on line 3

el contenido de la linea 3 es:

$conexion = mysqli_connect(

y sigue así

'localhost'
'admin'
'password'
'videoteca'
);


alguien me puede ayudar?
  #2 (permalink)  
Antiguo 06/04/2006, 05:30
 
Fecha de Ingreso: abril-2005
Mensajes: 53
Antigüedad: 12 años, 8 meses
Puntos: 0
Quita la "i" latina, es mysql_connect
  #3 (permalink)  
Antiguo 06/04/2006, 05:48
 
Fecha de Ingreso: junio-2005
Mensajes: 39
Antigüedad: 12 años, 5 meses
Puntos: 0
ahora he comprobado el fallo

la "i" es correcta, lo que pasa es que php no reconoce mysql como instalada.

no se por qué, pero yo le he puesto en el php.ini estas lineas:

extension=php_mysql.dll (A esta solo le he quitado el ; de delante)
extension=php_mysqli.dll

He comprobado que tengo las liberias y tanto mysql.dll como mysqli.dll están pero php no me reconoce ninguna de ellas.
  #4 (permalink)  
Antiguo 06/04/2006, 07:01
Avatar de jcxnet  
Fecha de Ingreso: octubre-2005
Ubicación: Perú
Mensajes: 784
Antigüedad: 12 años, 2 meses
Puntos: 56
Tienes que copiar la librería libmysql.dll, que se encuentra en tu directorio php, a la carpeta de sistema (SYSTEM o SYSTEM32).

Última edición por jcxnet; 06/04/2006 a las 08:17
  #5 (permalink)  
Antiguo 06/04/2006, 08:11
 
Fecha de Ingreso: junio-2005
Mensajes: 39
Antigüedad: 12 años, 5 meses
Puntos: 0
Ya lo he hecho y sigue igual
  #6 (permalink)  
Antiguo 06/04/2006, 08:19
Avatar de jcxnet  
Fecha de Ingreso: octubre-2005
Ubicación: Perú
Mensajes: 784
Antigüedad: 12 años, 2 meses
Puntos: 56
Reiniciaste Apache luego de copiar la dll a la carpeta de sistema ?
  #7 (permalink)  
Antiguo 06/04/2006, 08:41
 
Fecha de Ingreso: junio-2005
Mensajes: 39
Antigüedad: 12 años, 5 meses
Puntos: 0
Sonrisa

Reinicie el sistema entero. Y nada.

Pero he encontrado un paquete llamado wampserver (como el appserv) y este si tiene php 5 estable. Lo he instalado y a funcionado. Tiene instalado tanto la función mysql como la mysqli. Lo único que necesitaba es que funcionara para aprender PHP con MySQL. Cuando ya sepa dominarme volveré a este punto para profundizar en las configuraciones.

Muchas gracias de todos modos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:21.