Foros del Web » Programando para Internet » PHP »

Problema con RESUME en descargas

Estas en el tema de Problema con RESUME en descargas en el foro de PHP en Foros del Web. Hola, tengo problemas con la opción de resume en las descargas y no sé a que puede ser debido. Utilicé este script de las FAQ ...
  #1 (permalink)  
Antiguo 03/02/2004, 22:18
 
Fecha de Ingreso: enero-2002
Mensajes: 21
Antigüedad: 15 años, 10 meses
Puntos: 0
Problema con RESUME en descargas

Hola, tengo problemas con la opción de resume en las descargas y no sé a que puede ser debido.

Utilicé este script de las FAQ para gestionar descargas de video:

http://www.forosdelweb.com/showthrea...781#post306781

Al principio funcionaba perfectamente pero cambié de servidor y ha dejado de funcionar. Como el script es el mismo y no lo he tocado, creo que debe de ser algo de la configuración de PHP o del servidor. La descarga se realiza perfectamente pero sin resume, de manera que si se corta hay que volver a empezarla del principio, cosa que antes no sucedía. ¿alguna idea sobre lo que puede estar fallando?? ¿He de configurar algo en el php.ini que me haya saltado??

A ver si podeis ayudarme
Gracias
Angel.
  #2 (permalink)  
Antiguo 04/02/2004, 07:11
Avatar de Helbira  
Fecha de Ingreso: octubre-2001
Ubicación: Sevilla, España
Mensajes: 1.228
Antigüedad: 16 años, 1 mes
Puntos: 5
Te fijastes en la nota de la FAQ?

Pone que sólo funciona con Apache. El cambio de tu servidor no sería de Apache a IIS?

Nuse.. es lo primero que se me ocurre
__________________
BUSCO TELETRABAJO
Experiencia de mas de 4 años como desarrolladora web en PHP, ASP, XML, XSL, JavaScript, MySQL, PostGres, SQLServer, ...
  #3 (permalink)  
Antiguo 04/02/2004, 08:20
 
Fecha de Ingreso: enero-2002
Mensajes: 21
Antigüedad: 15 años, 10 meses
Puntos: 0
Hola Helbira, en ambos caso ha sido con Apache2, solo que cuando funcionaba estaba montado en Windows2000 y ahora en Linux. Lo he probado en windows2000 de nuevo y tampoco funciona. No sé a que puede ser debido.... Creo que debe ser por algo de la configuración de php o seguramente del apache... pero no se...

Saludos
Angel.
  #4 (permalink)  
Antiguo 04/02/2004, 09:00
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Ademas del servidor web, pone tambien que es solo como modulo de Apache, no como CGI.

Ademas, es un proceso que tambien depende del cliente. Si tu cliente no soporta resumir descargas, tampoco lo hara.

Suerte.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #5 (permalink)  
Antiguo 17/02/2004, 22:09
 
Fecha de Ingreso: enero-2002
Mensajes: 21
Antigüedad: 15 años, 10 meses
Puntos: 0
Hola, bueno después de varias semanas en las que he dejado esto a un lado para no comerme mucho el coco lo he retomado porque me hace falta de veras disponer de esta opción resume en mi servidor y el script este de las faq me viene de maravilla si consiguiera hacerlo funcionar.

He copiado el script tal cual que viene en las faq y he renombrado un ejecutable a "archivo.exe". No he tocado nada del script.. tal cual está en las faq y lo he probado en tres servidores, todo ellos con php sobre modulo apache, dos en linux y otro en windows2000. Y lo he probado con clientes explorer6, netscape6 y flashget.

En todos me da el mismo error. No permite el resume y aunque genera un archivo temporal, al retomar la descarga esta vuelve a comenzar desde el bite cero, machacando la anterior descarga.

Por favor, si alguien pudiera probarlo en su servidor y me confirmara que el fallo es del script y no de algo que yo esté haciendo mal, o viceversa, estaría muy agradecido. Y a partir de ahi ya ver como hago.

Saludos
Angel

Última edición por Atreyuk; 17/02/2004 a las 22:13
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:44.